New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Auto-conversion of books broken in latest version of plug-in #62

Closed
HarryT-MR opened this Issue Jan 4, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@HarryT-MR

HarryT-MR commented Jan 4, 2014

The latest version of the plug-in appears to have broken the auto-conversion of books when doing a "Send to Device". I have the plug-in configured to send books to the Kindle App (which only accepts Mobi format books) but now, when I do a "Send to Device", if the book doesn't have a Mobi format available, I get the message:

Could not upload the following books to the device, as no suitable formats were found. Convert the book(s) to a format support by your device first.

In the previous version of the plug-in, I got a different message, asking me if I wanted to auto-convert the books before sending them to the device.

Is it possible to restore the "Auto-convert" functionality of the plug-in, please?

Thanks!

GRiker added a commit that referenced this issue Jan 4, 2014

Kindle: change format_map to lower(), enabling auto-conversion if no …
…MOBI available (issue #62). GoodReader: escape filenames to allow for illegal POSIX characters.
@GRiker

This comment has been minimized.

Collaborator

GRiker commented Jan 4, 2014

Fixed in 1.3.4. This was an unintentional side effect of trying to add support for AZW3. Should be OK now.

@GRiker GRiker closed this Jan 4, 2014

@HarryT-MR

This comment has been minimized.

HarryT-MR commented Jan 4, 2014

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment