Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Linux/Wayland] Wrong app icon under KDE Plasma Wayland session #134

Open
glaubersm opened this Issue Sep 18, 2018 · 9 comments

Comments

Projects
None yet
3 participants
@glaubersm
Copy link

glaubersm commented Sep 18, 2018

How to reproduce issue:
Use some linux distribution with KDE Plasma desktop environment, start Plasma Wayland session, open Photoflare.
Expected behaviour: Photoflare icon visible in title bar and KDE Plasma panel.
Observer behaviour: Title bar and KDE Plasma panel show Wayland generic icon. See the screenshot.
Version of PhotoFlare: 1.5.5 community edition
Operating System: Arch Linux, KDE Plasma 5.14 beta desktop environment, Wayland session.

photoflare

@DylanC

This comment has been minimized.

Copy link
Contributor

DylanC commented Sep 23, 2018

@glaubersm - Thanks. I will do a test run on Kubuntu.

@DylanC

This comment has been minimized.

Copy link
Contributor

DylanC commented Sep 26, 2018

@glaubersm - Do I just need to rename the desktop file to fix this or do you have any information on the matter?

@glaubersm

This comment has been minimized.

Copy link
Author

glaubersm commented Sep 27, 2018

I don't know how to fix this bug. Sorry.

@DylanC

This comment has been minimized.

Copy link
Contributor

DylanC commented Sep 28, 2018

@glaubersm - No problem. Thanks for the reply anyway.

@daissi

This comment has been minimized.

Copy link
Contributor

daissi commented Oct 19, 2018

Isn't fixed by 19c09d7 ? Does 1.5.5.1 have the same issue? Maybe, we should use a vector icon to fix this. @DylanC Do you have the photoflare icon in svg format?

@DylanC

This comment has been minimized.

Copy link
Contributor

DylanC commented Oct 21, 2018

@daissi - Yes v1.5.5.1 has the same issue. I can add an SVG of the icon to the project.

@DylanC

This comment has been minimized.

Copy link
Contributor

DylanC commented Oct 21, 2018

@DylanC DylanC added the help wanted label Feb 9, 2019

@glaubersm

This comment has been minimized.

Copy link
Author

glaubersm commented Mar 9, 2019

@DylanC

This comment has been minimized.

Copy link
Contributor

DylanC commented Mar 11, 2019

@glaubersm - Thanks. I can give this a try for the upcoming v1.5.8 release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.