Permalink
Browse files

bug 2674: cssmin 3.0.1 requires PHP 5.2.4

git-svn-id: http://piwigo.org/svn/trunk@16278 68402e56-0260-453c-a942-63ccdbb3a9ee
  • Loading branch information...
mistic100 committed Jul 2, 2012
1 parent f99f5c1 commit ba6dfe6a341600ab34c7db8abca7bc985b3d25ad
Showing with 5 additions and 2 deletions.
  1. +5 −2 include/template.class.php
@@ -1364,8 +1364,11 @@ private static function process_js($file)
private static function process_css($file)
{
$css = self::process_css_rec($file);
require_once(PHPWG_ROOT_PATH.'include/cssmin.class.php');
$css = CssMin::minify($css, array('Variables'=>false));
if (version_compare(PHP_VERSION, '5.2.4', '>='))
{
require_once(PHPWG_ROOT_PATH.'include/cssmin.class.php');
$css = CssMin::minify($css, array('Variables'=>false));
}
$css = trigger_event('combined_css_postfilter', $css);
return $css;
}

0 comments on commit ba6dfe6

Please sign in to comment.