Skip to content
Permalink
Browse files

RTD is breaking on StrictVersion in setup.py (#615)

  • Loading branch information...
ssteinbach authored and meshula committed Nov 7, 2019
1 parent 8392360 commit 6d3268764f6b6d84db2274271eabd0ea28033990
Showing with 11 additions and 11 deletions.
  1. +7 −7 .readthedocs.yml
  2. +4 −4 setup.py
@@ -2,15 +2,15 @@
version: 2

build:
image: latest
image: latest

python:
version: 3.6
install:
- method: pip
path: .
extra_requirements:
- cmake
version: 3.7
install:
- method: pip
path: .
extra_requirements:
- cmake

submodules:
include: all
@@ -227,8 +227,8 @@ def build(self):
PIP_VERSION = pip.__version__
REQUIRED_PIP_VERSION = "6.0.0"
if (
distutils.version.StrictVersion(PIP_VERSION)
<= distutils.version.StrictVersion(REQUIRED_PIP_VERSION)
distutils.version.LooseVersion(PIP_VERSION)
<= distutils.version.LooseVersion(REQUIRED_PIP_VERSION)
):
sys.stderr.write(
"Your pip version is: '{}', OpenTimelineIO requires at least "
@@ -250,8 +250,8 @@ def build(self):

REQUIRED_SETUPTOOLS_VERSION = '20.5.0'
if (
distutils.version.StrictVersion(SETUPTOOLS_VERSION)
<= distutils.version.StrictVersion(REQUIRED_SETUPTOOLS_VERSION)
distutils.version.LooseVersion(SETUPTOOLS_VERSION)
<= distutils.version.LooseVersion(REQUIRED_SETUPTOOLS_VERSION)
):
sys.stderr.write(
"Your setuptools version is: '{}', OpenTimelineIO requires at least "

0 comments on commit 6d32687

Please sign in to comment.
You can’t perform that action at this time.