API Incompatible? #4302

Rioji101 opened this Issue Oct 30, 2016 · 6 comments


None yet

4 participants


Issue description:

So i downloaded a few plugins like adminfun, signshop and some other stuff but when i started start.cmd it said (?) that only adminfun loaded and started working. all the other plugins had text stating Incompatible API version. I looked at other posts like these and there people said to go use http://pmt.mcpe.me/api2/ but that didn't work, it said404 Not Found

nginx/1.4.6 (Ubuntu)

Steps to reproduce the issue:

  1. Download plugins (I dont know if my plugins were the cause, but here is a list of plugins i wanted to use

2. Start start.cmd
3. Results should be there.

OS and versions

  • PocketMine-MP: 1.6dev [Unleashed]
  • PHP: I don't know if this is supposed to be API or something....
  • OS:No clue..
    This server is running PocketMine-MP 1.6dev 「Unleashed」 implementing API version 2.0.0 for Minecraft: PE v0.15.10.0 alpha (protocol version 84)

    Crashdump, backtrace or other files

    I don't really know what to put here.... The server log?
    It just says (?) [Server thread/ERROR]: Could not load plugin 'Crate Keys': Incompatible API version (For example)

This is a PrintScreen? I took of the pugins folder...

And this is a PrintScreen i took of my PocketMine folder.

SOF3 commented Oct 30, 2016

API incompatible means API incompatible. What else do you expect? Do you report to Nokia saying that you can't install WhatsApp on Nokia 3310?


Still... Economy and those EconomyShop things say they support 2.0.0 and i have 2.0.0


You only got the version of plugin. Not the API version


Economy still use old API.


Alternatively you can edit the .yml to load on API 2.0.0 - 2.1.0, but that is not recommended as the code is outdated (like in 1.14.0) and it may have issues. Try getting a new version of the plugin that supports API 2.0.0+

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment