This repository has been archived by the owner. It is now read-only.

contOS7 php7 #4339

Closed
erxat124 opened this Issue Apr 25, 2017 · 9 comments

Comments

Projects
None yet
6 participants
@erxat124

erxat124 commented Apr 25, 2017

system: centOS 7 64x
How to do this
etmc@zhujiwu ~]$ ls
bin LICENSE PocketMine-MP.phar.sig start.sh
CONTRIBUTING.md PocketMine-MP.phar README.md
[etmc@zhujiwu ~]$ ./start.sh
Couldn't find a working PHP 7 binary, please use the installer.
[etmc@zhujiwu ~]$

@Mooncoder

This comment has been minimized.

Show comment
Hide comment
@Mooncoder

Mooncoder May 23, 2017

Try reinstalling it and try again.

Mooncoder commented May 23, 2017

Try reinstalling it and try again.

@OpnSrcConstruction

This comment has been minimized.

Show comment
Hide comment
@OpnSrcConstruction

OpnSrcConstruction May 31, 2017

I am having he same problem except on an Ubuntu 16.04 LTS based OS, and a 17.04 Ubuntu Gnome OS. The problem is the same... php7 is installed by default, but the website bash command && the master branch; don't install php7 or accept the php7 binary in the OS.

OpnSrcConstruction commented May 31, 2017

I am having he same problem except on an Ubuntu 16.04 LTS based OS, and a 17.04 Ubuntu Gnome OS. The problem is the same... php7 is installed by default, but the website bash command && the master branch; don't install php7 or accept the php7 binary in the OS.

@TheDiamondYT1

This comment has been minimized.

Show comment
Hide comment
@TheDiamondYT1

TheDiamondYT1 May 31, 2017

We've moved.

A long time ago, actually. The official PocketMine-MP repo has moved and this repo will not be updated ever again.

https://github.com/pmmp/PocketMine-MP

TheDiamondYT1 commented May 31, 2017

We've moved.

A long time ago, actually. The official PocketMine-MP repo has moved and this repo will not be updated ever again.

https://github.com/pmmp/PocketMine-MP

@TheDiamondYT1

This comment has been minimized.

Show comment
Hide comment
@TheDiamondYT1

TheDiamondYT1 May 31, 2017

Also this issue is a support request and should be asked on the new forums

TheDiamondYT1 commented May 31, 2017

Also this issue is a support request and should be asked on the new forums

@OpnSrcConstruction

This comment has been minimized.

Show comment
Hide comment
@OpnSrcConstruction

OpnSrcConstruction May 31, 2017

This project is a joke anyways. One shouldn't have to build php7 from source, to be able to run your server. I got a version to run from an outdated installer, but couldn't connect from it being too old. If this repo is outdated, and you don't want to make it private; then backup the code and delete it. The web-site is broken unless you use corporation controlled software(apple/M$). I file bug-reports and they constantly get shot down for stupid issues like above. I just want a simple installer script, for a version; that the current minecraftPE will connect to.

OpnSrcConstruction commented May 31, 2017

This project is a joke anyways. One shouldn't have to build php7 from source, to be able to run your server. I got a version to run from an outdated installer, but couldn't connect from it being too old. If this repo is outdated, and you don't want to make it private; then backup the code and delete it. The web-site is broken unless you use corporation controlled software(apple/M$). I file bug-reports and they constantly get shot down for stupid issues like above. I just want a simple installer script, for a version; that the current minecraftPE will connect to.

@TheDiamondYT1

This comment has been minimized.

Show comment
Hide comment
@TheDiamondYT1

TheDiamondYT1 May 31, 2017

@OpnSrcConstruction Then download the pre-compiled binaries...

Standard PHP installations dont come with the requires extensions, so pocketmine provides them for you. You are a joke

TheDiamondYT1 commented May 31, 2017

@OpnSrcConstruction Then download the pre-compiled binaries...

Standard PHP installations dont come with the requires extensions, so pocketmine provides them for you. You are a joke

@PainTR

This comment has been minimized.

Show comment
Hide comment
@PainTR

PainTR Jun 1, 2017

try to change php5 text to php7 in your start.sh file
PHP_BINARY="./bin/php5/bin/php"

PHP_BINARY="./bin/php7/bin/php"

PainTR commented Jun 1, 2017

try to change php5 text to php7 in your start.sh file
PHP_BINARY="./bin/php5/bin/php"

PHP_BINARY="./bin/php7/bin/php"

@dktapps

This comment has been minimized.

Show comment
Hide comment
@dktapps

dktapps Jun 1, 2017

Member

@TheDiamondYT just fucking quit already... if people are too stupid to see the notice on the readme, don't waste your time on them. You're just spamming people's notifications for no good reason.

Member

dktapps commented Jun 1, 2017

@TheDiamondYT just fucking quit already... if people are too stupid to see the notice on the readme, don't waste your time on them. You're just spamming people's notifications for no good reason.

@TheDiamondYT1

This comment has been minimized.

Show comment
Hide comment
@TheDiamondYT1

TheDiamondYT1 commented Jun 1, 2017

Lol k

@dktapps dktapps closed this Dec 31, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.