Fail to install with Node 0.6.14 #3

Closed
murvinlai opened this Issue Apr 8, 2012 · 4 comments

Comments

Projects
None yet
3 participants

I have udpated node to 0.6.14 and then install like this:

sudo npm install xml2js-expat

(on ubuntu)

and I get error below. any idea what problem is that?

npm http GET https://registry.npmjs.org/xml2js-expat
npm http 304 https://registry.npmjs.org/xml2js-expat
npm http GET https://registry.npmjs.org/node-expat
npm http 304 https://registry.npmjs.org/node-expat

node-expat@1.4.5 install /node_modules/xml2js-expat/node_modules/node-expat
node-waf configure build

Checking for program g++ or c++ : /usr/bin/g++
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for g++ : ok
Checking for node path : not found
Checking for node prefix : ok /usr/local
Checking for header expat.h : not installed
/node_modules/xml2js-expat/node_modules/node-expat/wscript:13: error: the configuration failed (see '/node_modules/xml2js-expat/node_modules/node-expat/build/config.log')

npm ERR! node-expat@1.4.5 install: node-waf configure build
npm ERR! sh "-c" "node-waf configure build" failed with 1
npm ERR!
npm ERR! Failed at the node-expat@1.4.5 install script.
npm ERR! This is most likely a problem with the node-expat package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-waf configure build
npm ERR! You can get their info via:
npm ERR! npm owner ls node-expat
npm ERR! There is likely additional logging output above.
npm ERR!
npm ERR! System Linux 2.6.38-8-virtual
npm ERR! command "node" "/usr/local/bin/npm" "install" "xml2js-expat"
npm ERR! cwd /
npm ERR! node -v v0.6.14
npm ERR! npm -v 1.1.12
npm ERR! code ELIFECYCLE
npm ERR! message node-expat@1.4.5 install: node-waf configure build
npm ERR! message sh "-c" "node-waf configure build" failed with 1
npm ERR! errno {}
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /npm-debug.log
npm not ok

Owner

Poetro commented Apr 9, 2012

This is an issue of node-expat which xml2js-expat depends on.

ok. let me put an issue on node-expat then. :) thanks.

astro commented Apr 9, 2012

apt-get install libexpat1-dev

Thanks. It works now.

On Mon, Apr 9, 2012 at 2:55 PM, Astro <
reply@reply.github.com

wrote:

apt-get install libexpat1-dev


Reply to this email directly or view it on GitHub:
#3 (comment)

Poetro closed this Apr 11, 2012

murvinlai referenced this issue in astro/node-expat Apr 26, 2012

Closed

Uncompatible with Node 6.0.14? #34

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment