New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

file.edit is not working on latest RStudio on Windows #209

Closed
eliotmcintire opened this Issue Aug 5, 2015 · 4 comments

Comments

Projects
None yet
2 participants
@eliotmcintire
Contributor

eliotmcintire commented Aug 5, 2015

this means that openModules and newModule don't work.

Tried numerous solutions, and the only one that works was to hard code the file path to RStudio, which is a bad solution.

Identified as an RStudio bug:
https://stat.ethz.ch/pipermail/r-help//2014-September/421513.html

@achubaty achubaty added the invalid label Aug 10, 2015

@achubaty

This comment has been minimized.

Contributor

achubaty commented Aug 10, 2015

closing, as this is not a SpaDES issue

@achubaty achubaty closed this Aug 10, 2015

@eliotmcintire

This comment has been minimized.

Contributor

eliotmcintire commented Aug 10, 2015

But we need to change the default, which is open the new file. We should
maybe provide a tryCatch with a message...

On Mon, Aug 10, 2015, 1:38 PM Alex Chubaty notifications@github.com wrote:

closing, as this is not a SpaDES issue


Reply to this email directly or view it on GitHub
#209 (comment)
.

@achubaty

This comment has been minimized.

Contributor

achubaty commented Oct 29, 2015

just forked the Rstudio repo and fixed this issue.

achubaty/rstudio@378ae10

hoping to submit pull request soon (pending copyright transfer agreement form)

achubaty added a commit that referenced this issue Oct 29, 2015

achubaty added a commit that referenced this issue Nov 4, 2015

remove temp (incomplete) fix for #209
R CMD check complains, so removing for now

reverts changes from e677cde
and d1f8af3
@achubaty

This comment has been minimized.

Contributor

achubaty commented Nov 19, 2015

using tryCatch as the workaround for now rather than fussing with patching Rstudio.

@achubaty achubaty self-assigned this Nov 19, 2015

@achubaty achubaty added this to the v1.0.4 milestone Nov 19, 2015

@achubaty achubaty added resolved in branch and removed invalid labels Nov 19, 2015

achubaty added a commit that referenced this issue Nov 19, 2015

workaround to close #209
* warn instead of error when using e.g., `newModule` with Rstudio on
Windows

@achubaty achubaty referenced this issue Dec 18, 2015

Closed

Development #240

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment