New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Archived posts are not appearing in Nominated #923

Closed
regan008 opened this Issue May 23, 2017 · 20 comments

Comments

4 participants
@regan008
Contributor

regan008 commented May 23, 2017

When a nominated post is archived, filter by archived does not return any results.

@regan008 regan008 added the bug label May 23, 2017

@regan008 regan008 added this to the 4.3.x milestone May 23, 2017

@regan008

This comment has been minimized.

Show comment
Hide comment
@regan008

regan008 May 23, 2017

Contributor

Related to #889

Contributor

regan008 commented May 23, 2017

Related to #889

@regan008 regan008 added this to TODO in BugFixes May 23, 2017

@yoannspace

This comment has been minimized.

Show comment
Hide comment
@yoannspace

yoannspace Oct 4, 2017

Contributor

Should be modified to "removed_feed_item" instead of "draft"?
https://github.com/PressForward/pressforward/blob/4.4.x/includes/functions.php#L967

Contributor

yoannspace commented Oct 4, 2017

Should be modified to "removed_feed_item" instead of "draft"?
https://github.com/PressForward/pressforward/blob/4.4.x/includes/functions.php#L967

@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Oct 17, 2017

Member

@yoannspace Thank you for your contribution. We're engaging in testing it now, but it looks like this is definitely a bug and you've done a great job spotting the issue and fixing it!

Member

AramZS commented Oct 17, 2017

@yoannspace Thank you for your contribution. We're engaging in testing it now, but it looks like this is definitely a bug and you've done a great job spotting the issue and fixing it!

@AramZS AramZS modified the milestones: 4.3.x, 5.0 Oct 17, 2017

@AramZS AramZS added the Blessed label Oct 17, 2017

AramZS added a commit that referenced this issue Oct 17, 2017

Merge pull request #942 from DARIAH-ERIC/4.4.x
Fixing the display of archived items, should resolve #923

@AramZS AramZS added the Test label Oct 18, 2017

@regan008

This comment has been minimized.

Show comment
Hide comment
@regan008

regan008 Oct 23, 2017

Contributor

@jccatalano I think this is ready to test

Contributor

regan008 commented Oct 23, 2017

@jccatalano I think this is ready to test

@jccatalano

This comment has been minimized.

Show comment
Hide comment
@jccatalano

jccatalano Oct 23, 2017

I am still experiencing a problem with issue #923. Archived only is still not displaying archived posts. The toggle visibility of archived is working though.

jccatalano commented Oct 23, 2017

I am still experiencing a problem with issue #923. Archived only is still not displaying archived posts. The toggle visibility of archived is working though.

AramZS added a commit that referenced this issue Oct 24, 2017

We no longer include archived content inline with the standard query
Removing show archived to move to only archived or no archived. #923
@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Oct 24, 2017

Member

Please try again with latest

Member

AramZS commented Oct 24, 2017

Please try again with latest

@jccatalano

This comment has been minimized.

Show comment
Hide comment
@jccatalano

jccatalano Oct 25, 2017

I am still having an issue with this. Archived posts from February are showing up in archived only. But the posts that I brought in today and archived do not appear.

jccatalano commented Oct 25, 2017

I am still having an issue with this. Archived posts from February are showing up in archived only. But the posts that I brought in today and archived do not appear.

@yoannspace

This comment has been minimized.

Show comment
Hide comment
@yoannspace

yoannspace Oct 30, 2017

Contributor

Would that be possible that's because it is in an other page? But you can't go to other pages (see #945)?
Some thing must have changed lately, but I experienced the same problem with new archived content, they would show up at the end (last page)... I modified this:
ORDER BY {$wpdb->postmeta}.meta_value DESC, {$wpdb->posts}.post_date DESC
on https://github.com/PressForward/pressforward/blob/4.4.x/includes/functions.php#L972 so that the archive objects appear with newest at top.
But that also means, that the waiting pull request be accepted (to have pagination in archived items).

Contributor

yoannspace commented Oct 30, 2017

Would that be possible that's because it is in an other page? But you can't go to other pages (see #945)?
Some thing must have changed lately, but I experienced the same problem with new archived content, they would show up at the end (last page)... I modified this:
ORDER BY {$wpdb->postmeta}.meta_value DESC, {$wpdb->posts}.post_date DESC
on https://github.com/PressForward/pressforward/blob/4.4.x/includes/functions.php#L972 so that the archive objects appear with newest at top.
But that also means, that the waiting pull request be accepted (to have pagination in archived items).

@AramZS AramZS removed the Test label Nov 28, 2017

@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Dec 5, 2017

Member

@yoannspace Thanks for the PR, we'll review it.

@regan008 Can you please test this change on the branch 4.4.x-stats-nomination-add-archives-pagination to see if it resolves this issue?

Member

AramZS commented Dec 5, 2017

@yoannspace Thanks for the PR, we'll review it.

@regan008 Can you please test this change on the branch 4.4.x-stats-nomination-add-archives-pagination to see if it resolves this issue?

AramZS added a commit that referenced this issue Dec 5, 2017

@jccatalano

This comment has been minimized.

Show comment
Hide comment
@jccatalano

jccatalano Dec 5, 2017

I am still having problems with this issue.
User 1: Nominates an item from all content (the item appears in nominated)
User 1: Archives the item from Nominated (the item vanishes from Nominated)
User 1: Filters by Archive Only (the archived item is not there)
User 1: Goes to All Content (the item is no longer in all content)

jccatalano commented Dec 5, 2017

I am still having problems with this issue.
User 1: Nominates an item from all content (the item appears in nominated)
User 1: Archives the item from Nominated (the item vanishes from Nominated)
User 1: Filters by Archive Only (the archived item is not there)
User 1: Goes to All Content (the item is no longer in all content)

@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Dec 5, 2017

Member

@jccatalano Does the page refresh when you use the filter?

Member

AramZS commented Dec 5, 2017

@jccatalano Does the page refresh when you use the filter?

@AramZS AramZS added the Test label Dec 5, 2017

@yoannspace

This comment has been minimized.

Show comment
Hide comment
@yoannspace

yoannspace Dec 5, 2017

Contributor

SQL_CALC_FOUND_ROWS disappeared on:
https://github.com/PressForward/pressforward/blob/4.4.x-stats-nomination-add-archives-pagination/includes/functions.php#L965

ORDER BY {$wpdb->postmeta}.meta_value DESC, {$wpdb->posts}.post_date DESC was not added on:
https://github.com/PressForward/pressforward/blob/4.4.x-stats-nomination-add-archives-pagination/includes/functions.php#L973

$page += 1; disappeared on:
https://github.com/PressForward/pressforward/blob/4.4.x-stats-nomination-add-archives-pagination/Core/Admin/Nominated.php#L290

@AramZS There might be reasons for those, and I would be happy to hear them and I will try to change it to something you would prefer.

Contributor

yoannspace commented Dec 5, 2017

SQL_CALC_FOUND_ROWS disappeared on:
https://github.com/PressForward/pressforward/blob/4.4.x-stats-nomination-add-archives-pagination/includes/functions.php#L965

ORDER BY {$wpdb->postmeta}.meta_value DESC, {$wpdb->posts}.post_date DESC was not added on:
https://github.com/PressForward/pressforward/blob/4.4.x-stats-nomination-add-archives-pagination/includes/functions.php#L973

$page += 1; disappeared on:
https://github.com/PressForward/pressforward/blob/4.4.x-stats-nomination-add-archives-pagination/Core/Admin/Nominated.php#L290

@AramZS There might be reasons for those, and I would be happy to hear them and I will try to change it to something you would prefer.

@jccatalano

This comment has been minimized.

Show comment
Hide comment
@jccatalano

jccatalano Dec 5, 2017

Yes it refreshes.

jccatalano commented Dec 5, 2017

Yes it refreshes.

@jccatalano

This comment has been minimized.

Show comment
Hide comment
@jccatalano

jccatalano Dec 5, 2017

From the console when I click show Archived Only:

screen shot 2017-12-05 at 11 12 20 am

jccatalano commented Dec 5, 2017

From the console when I click show Archived Only:

screen shot 2017-12-05 at 11 12 20 am

@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Dec 5, 2017

Member

@yoannspace The page += 1 issue had to do with a bug in how the infinite scroll JS works. In my testing, removing it seems to cause issues with that feature. I neglected to add the ordering at 973 and I was testing on the found rows issue, but it does look needed, so I am adding it back in.

Member

AramZS commented Dec 5, 2017

@yoannspace The page += 1 issue had to do with a bug in how the infinite scroll JS works. In my testing, removing it seems to cause issues with that feature. I neglected to add the ordering at 973 and I was testing on the found rows issue, but it does look needed, so I am adding it back in.

@yoannspace

This comment has been minimized.

Show comment
Hide comment
@yoannspace

yoannspace Dec 5, 2017

Contributor

I checked your last commit. It works for me, I can see my last archived items. But when I get on page 2, then the pagination is messed up. That's where the '$page +=1;' was helping out.

Contributor

yoannspace commented Dec 5, 2017

I checked your last commit. It works for me, I can see my last archived items. But when I get on page 2, then the pagination is messed up. That's where the '$page +=1;' was helping out.

@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Dec 5, 2017

Member

@yoannspace What version of WordPress and Browser are you using?

I'll test this now.

Member

AramZS commented Dec 5, 2017

@yoannspace What version of WordPress and Browser are you using?

I'll test this now.

@AramZS

This comment has been minimized.

Show comment
Hide comment
@AramZS

AramZS Dec 5, 2017

Member

@yoannspace I'm going to put it back in and we'll test it. I tried solving the issue by changing the numbers elsewhere and it didn't work, but changing it here doesn't seem to cause any issues.

Member

AramZS commented Dec 5, 2017

@yoannspace I'm going to put it back in and we'll test it. I tried solving the issue by changing the numbers elsewhere and it didn't work, but changing it here doesn't seem to cause any issues.

AramZS added a commit that referenced this issue Dec 5, 2017

Putting page+1 back in as, in testing, this positioning works
The problem the page number hacking resolves happens further up, so as long as the +1 occurs here, it shouldn't cause issues elsewhere. Props @yoannspace #923
@jccatalano

This comment has been minimized.

Show comment
Hide comment
@jccatalano

jccatalano Dec 5, 2017

It appears that this issue is resolved by clearing the cache.

jccatalano commented Dec 5, 2017

It appears that this issue is resolved by clearing the cache.

@jccatalano jccatalano closed this Dec 5, 2017

@yoannspace

This comment has been minimized.

Show comment
Hide comment
@yoannspace

yoannspace Dec 6, 2017

Contributor

@AramZS Definitely too late, but I use Firefox 57.0.1 / Wordpress 4.8.4

Thanks all!

Contributor

yoannspace commented Dec 6, 2017

@AramZS Definitely too late, but I use Firefox 57.0.1 / Wordpress 4.8.4

Thanks all!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment