Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Emails files are not completely translated on prestashop 1.7.6 #14633

Closed
maofree opened this issue Jul 13, 2019 · 11 comments

Comments

@maofree
Copy link

commented Jul 13, 2019

Hi
I've upgraded from 1.7.5.2, all is ok except the email files
I've seen that the emails files are not completely translated
I've already updated the translations from back-office
it happens for many translations like italian, spanish ...

bye

Screenshots
1

Additional information
PrestaShop version: 1.7.6
PHP version: 7.2

@mariem-abid

This comment has been minimized.

Copy link

commented Jul 15, 2019

Hi @maofree,

Do you have made the update translations before or after the upgrade?

@maofree

This comment has been minimized.

Copy link
Author

commented Jul 15, 2019

After

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Jul 16, 2019

@maofree, thanks for your feedback.
I have the same issue after upgrade from PS1.7.5 to PS1.7.6.0 using the 1-click upgrade v4.9.0.

In fact, in the BO => International => translation =>

  • Type of translation => Email translations
  • Select the type of email content => Body
  • Select your theme => Core
  • Select your language => Italian

When we click for example on "Core emails" link => order_conf => some strings are not translated

I attached a screen record
https://drive.google.com/file/d/1MTDc5LURUxc1Z7axVKdlahjfPSioRJ3Z/view

PS: I tried to edit the "Edit HTML" version => ok
ping @jolelievre what do you think?

Thanks!

@jameshellfire

This comment has been minimized.

Copy link

commented Jul 16, 2019

A temporary baypass is: change e-mail templates to classic.
In new added menu.:
image

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Jul 16, 2019

Hi,

As discussed with @jolelievre, this is a bug & it is a regression.
In fact, In the PS1.7.5.2 is different from PS1.7.6 but emails are well translated.
I’ll add this to the debug roadmap so that it’s fixed. If you have already fixed it on your end or if you think you can do it, please do send us a pull request!
Thanks!

@marionf marionf added this to Backlog in PrestaShop 1.7.6 via automation Jul 16, 2019

@marionf marionf moved this from Backlog to To do in PrestaShop 1.7.6 Jul 16, 2019

@marionf marionf removed the Autoupgrade label Jul 16, 2019

@jolelievre jolelievre changed the title emails files are not completely translated on prestashop 1.7.6 Emails files are not completely translated on prestashop 1.7.6 Jul 17, 2019

@jolelievre jolelievre self-assigned this Jul 17, 2019

@jolelievre jolelievre moved this from To do to In progress in PrestaShop 1.7.6 Jul 17, 2019

@jolelievre jolelievre moved this from In progress to To be reviewed in PrestaShop 1.7.6 Jul 17, 2019

@jolelievre

This comment has been minimized.

Copy link
Contributor

commented Jul 19, 2019

Indeed some translation keys were missing in the catalog, so they couldn't be translated in crowdin. We fixed this issue so the missing keys will be published in crowdin as soon as this PR will be merged.

@md-brnursery

This comment has been minimized.

Copy link

commented Jul 26, 2019

Any update on this, when I have installed the update 1.7.6, the shop name has been replaced with "My Shop"?

@liviu-v

This comment has been minimized.

Copy link

commented Aug 5, 2019

No fix for this issue yet?!?

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Aug 5, 2019

Hi @liviu-v,

Here's the PR: #14719 to fix the issue & it should be reviewed by our developers.

Thanks!

@marionf marionf moved this from To be reviewed to In progress in PrestaShop 1.7.6 Aug 5, 2019

@liviu-v

This comment has been minimized.

Copy link

commented Aug 5, 2019

@khouloudbelguith Thank You very much for your fast reply! Pardon me but I am new in here, what exactlly does it mean, like aproximativlly when this error will be resolve by your delevopers? and I will find the fix for this issue in the PR #14719 or here in this issue: #14633, now is in progress correct?

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Aug 5, 2019

@liviu-v, it should be fixed in a few days.
Yes, this is the fix https://github.com/PrestaShop/PrestaShop/pull/14719/files, it will be added in the next version PS1.7.6.1.
Thanks!

@jolelievre jolelievre moved this from In progress to To be reviewed in PrestaShop 1.7.6 Aug 7, 2019

@marionf marionf moved this from To be reviewed to To be tested in PrestaShop 1.7.6 Aug 7, 2019

@marionf marionf moved this from To be tested to To be reviewed in PrestaShop 1.7.6 Aug 7, 2019

@eternoendless eternoendless moved this from To be reviewed to To be tested in PrestaShop 1.7.6 Aug 8, 2019

@jolelievre jolelievre moved this from To be tested to To be merged in PrestaShop 1.7.6 Aug 8, 2019

@marionf marionf added Fixed and removed To Do labels Aug 8, 2019

@marionf marionf closed this Aug 8, 2019

PrestaShop 1.7.6 automation moved this from To be merged to Done Aug 8, 2019

@marionf marionf added this to the 1.7.6.1 milestone Aug 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.