Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When I install a new language, the generated emails are not translated on first generation #16273

Closed
jolelievre opened this issue Nov 5, 2019 · 4 comments

Comments

@jolelievre
Copy link
Contributor

@jolelievre jolelievre commented Nov 5, 2019

Describe the bug
When I install a new language, the generated emails are not translated on first generation

To Reproduce
Steps to reproduce the behavior:

  1. Go to International > Translations
  2. Install new language "Polish"
  3. The mails are generated in mails/pl but they are in englisg
  4. If you regenerate them manually after it works fine

Solution
Check the update package part of the code, seems like the translations are not available
Maybe the translations are cached on the start of the request, so when mails are generated the new one is not available, maybe we should clean the cache right after the new language is installed

Additional information
PrestaShop version: 1.7.6
PHP version: N/A

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

@khouloudbelguith khouloudbelguith commented Nov 5, 2019

Hi @jolelievre,

I have the same issue with PS1.7.6.1 & PS1.7.6.2build1.
pl.zip

It is OK with PS1.7.5.2.
pl.zip

I’ll add this to the debug roadmap.
Thanks!

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

@khouloudbelguith khouloudbelguith commented Nov 5, 2019

Ping @PrestaShop/prestashop-product-team what do you think?
It should be fixed in the PS1.7.6.2 patch?

Thanks!

@colinegin colinegin added this to Backlog in PrestaShop 1.7.6 via automation Nov 5, 2019
@colinegin colinegin moved this from Backlog to To do in PrestaShop 1.7.6 Nov 5, 2019
@matks matks moved this from To do to In progress in PrestaShop 1.7.6 Nov 6, 2019
@matks matks removed the To Do label Nov 6, 2019
@colinegin colinegin moved this from In progress to To be reviewed in PrestaShop 1.7.6 Nov 6, 2019
@colinegin colinegin moved this from To be reviewed to In progress in PrestaShop 1.7.6 Nov 18, 2019
@colinegin colinegin moved this from In progress to To be reviewed in PrestaShop 1.7.6 Nov 20, 2019
@colinegin colinegin moved this from To be reviewed to To be tested in PrestaShop 1.7.6 Nov 20, 2019
@colinegin colinegin moved this from To be tested to In progress in PrestaShop 1.7.6 Nov 21, 2019
@matks matks moved this from In progress to To be tested in PrestaShop 1.7.6 Nov 21, 2019
@matks

This comment has been minimized.

Copy link
Contributor

@matks matks commented Nov 21, 2019

Might be fixed by #16294

@Robin-Fischer-PS Robin-Fischer-PS moved this from To be tested to In progress in PrestaShop 1.7.6 Nov 21, 2019
@colinegin colinegin moved this from In progress to Backlog in PrestaShop 1.7.6 Nov 26, 2019
@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

@khouloudbelguith khouloudbelguith commented Nov 26, 2019

Same issue with PS1.7.6.0

@colinegin colinegin moved this from Backlog to To do in PrestaShop 1.7.6 Dec 4, 2019
@MatShir MatShir moved this from To do to In progress in PrestaShop 1.7.6 Dec 4, 2019
@Robin-Fischer-PS Robin-Fischer-PS moved this from In progress to To be merged in PrestaShop 1.7.6 Dec 6, 2019
@Robin-Fischer-PS Robin-Fischer-PS added this to the 1.7.6.3 milestone Dec 6, 2019
@marionf marionf added the Fixed label Dec 6, 2019
@marionf marionf closed this Dec 6, 2019
PrestaShop 1.7.6 automation moved this from To be merged to Done Dec 6, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
6 participants
You can’t perform that action at this time.