New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[BOOM-3455] Add new referrer error #9942

Closed
prestonBot opened this Issue Aug 22, 2018 · 7 comments

Comments

3 participants
@prestonBot
Copy link
Collaborator

prestonBot commented Aug 22, 2018

This issue has been migrated from the Forge. Read the original ticket here.

  • Reporter: nidecondor
  • Created at: Wed, 12 Jul 2017 15:07:43 +0200

Dans Trafic et SEO > Affiliation, il m'est impossible d'ajouter un affilié, j'ai toujours l'erreur suivante en mettant un mdp de 8 caractères par exemple : "La longueur du champ Referrer >passwd est actuellement 60 caractères. Il doit être entre 0 et 32 caractères."

  • How to reproduce the issue ?

N/A

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: marion_francois
  • Created at: Wed, 26 Jul 2017 15:49:42 +0200

Je reproduis le problème

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: davidm27
  • Created at: Sat, 30 Dec 2017 13:52:21 +0100

The only workaround that I've found is by entering the user without a password.

I've already tried to extend the password column under p_referrer from varchar32 to varchar128. It didn't work.

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: juan.diegomdc
  • Created at: Wed, 3 Jan 2018 18:21:37 +0100

Hi, I have the same issue and other derivated from this one.

I think the problem is the way in which the password is saved, because it is saved with the new method. While all the source code and the database are ready to use the old method.

When i create a new referrer to login in /modules/trackingfront/stats.php i have the same error:
Referrer->passwd is currently 60 chars. It must be between 0 and 32 chars.
I going to edit the ReferrerCore Class and change the zize from 32 to 64
'passwd' => array('type' => self::TYPE_STRING, 'validate' => 'isPasswd', 'size' => 64)

You need alter the database too

ALTER TABLE `'.DB_PREFIX.'referrer`
CHANGE COLUMN `passwd` `passwd` VARCHAR(64) NULL DEFAULT NULL AFTER `name`;

And that make works to create the referrer but that create a problem to me. I can't login with my user and password.

The error that I see is that password dont works in the module beacuse it's encrypted in a new method (i think maybe is crypt() but i'm not sure) but the module still using the old method.

i Have to change the data in referrer table using this update:
UPDATE '.DB_PREFIX.'referrer` SET `passwd`=md5('$cookie_key12345') 
WHERE `id_referrer`=1;

change the $cookie_key var for your parameter in /app/config/parameters.php and then you can connect with your username and your password will be 12345

 

I hope my information helps you a little to understand what happens and that it is resolved for the next version, i'm testing im my localhost the version 1.7.2.4

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

Version prestashop 1.7.1,

Idem, de plus, le fichier login.tpl pose problème chez moi.

Le problème vient de la ligne 
{include file="$tpl_dir./errors.tpl"}
 

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: dopkay
  • Created at: Mon, 21 May 2018 17:40:55 +0200

Bonjour,

Même problème ici avec la version 1.7.2.4.

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: wfpaisa
  • Created at: Tue, 22 May 2018 01:25:46 +0200

Hi, I the same problem:

@prestonBot

This comment has been minimized.

Copy link
Collaborator

prestonBot commented Aug 22, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: khouloud.belguith
  • Created at: Tue, 22 May 2018 09:32:01 +0200

Hi all,

Sorry not yet, it is added to our bug roadmap.
There are some major issues to solve before this one.
So, it will probably not solved right now.
But PrestaShop is an open source project, so it can be solved before if someone submits a pull request to solve it.

Best regards, Khouloud

@colinegin colinegin added this to To do in PrestaShop 1.7.6 via automation Oct 26, 2018

@colinegin colinegin added this to the 1.7.6.0 milestone Oct 26, 2018

@marionf marionf added this to To do in PrestaShop 1.7.5 via automation Oct 29, 2018

@marionf marionf removed this from To do in PrestaShop 1.7.6 Oct 29, 2018

@marionf marionf modified the milestones: 1.7.6.0, 1.7.5.0 Oct 29, 2018

@marionf marionf removed the To Do label Oct 29, 2018

@marionf marionf moved this from To do to To be reviewed in PrestaShop 1.7.5 Oct 29, 2018

@marionf marionf moved this from To be reviewed to In progress in PrestaShop 1.7.5 Oct 29, 2018

@marionf marionf moved this from In progress to To be reviewed in PrestaShop 1.7.5 Oct 30, 2018

@marionf marionf moved this from To be reviewed to Done in PrestaShop 1.7.5 Nov 2, 2018

@marionf marionf added the Fixed label Nov 2, 2018

@marionf marionf closed this Nov 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment