Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[BOOM-2690] Carrier selection on FO #9998

Open
prestonBot opened this issue Aug 23, 2018 · 19 comments

Comments

@prestonBot
Copy link
Collaborator

commented Aug 23, 2018

This issue has been migrated from the Forge. Read the original ticket here.

  • Reporter: fred04
  • Created at: Tue, 21 Mar 2017 12:16:48 +0100

Je viens de faire des tests supplémentaires sur la béta 1.7.1.0
réglages : dans l'admin dans les préférences de transports je trie sur les positions et par ordre croissant

Transporteur A (gratuit)
Transporteur B (5€)
Transporteur C (3€)
Transporteur D (gratuit)
Transporteur E (10€)
Transporteur F (100€)

Produit 1 livrable avec transporteur A ou B
Produit 2 livrable avec transporteur C ou D
Produit 3 livrable avec transporteur E ou F

  • Si je mets au panier un produit individuellement, c'est OK il y a bien deux transporteurs proposés à chaque fois.
  • Par contre :
  • si je mets au panier produit 1 et produit 2 (dans cet ordre), Prestashop me propose
    le nom du transporteur C avec le tarif A+C
    le nom du transporteur D avec le tarif A+D
  • si je mets au panier produit 2 et produit 1 (dans cet ordre), Prestashop me propose
    le nom du transporteur A avec le tarif A+C
    le nom du transporteur A avec le tarif A+D
    [Bug 1 : ] ce n'est pas normal que l'ordre d'ajout au panier modifie le nom du transporteur affiché
    [Bug 2 : ] ou est le transporteur B ?? il est puni ? c'est un problème si A est un retrait chez le commerçant et B une livraison => les clients sont donc obligés de venir physiquement retirer leur commandes
  • si je mets au panier produit 1 et produit 3 (dans cet ordre), Prestashop me propose
    le nom du transporteur E avec le tarif E (A+E peut-être ?)
    [Bug 3 : ] pourquoi uniquement celui-là ? pas le choix avec F ou A+F ?
  • si je mets au panier produit 3 et produit 1 (dans cet ordre), Prestashop me propose
    le nom du transporteur A avec le tarif E (A+E peut-être ?)
    [Bug 4 : ] encore problème de nom, mais dans le cas où A est un retrait en magasin on facture 10€ pour ce retrait
  • si je mets au panier produit 1 + produit 2 + produit 3 (dans cet ordre), Prestashop me propose
    le nom du transporteur E avec le tarif A+C+E
    le nom du transporteur E avec le tarif A+D+E
    [Bug 5 : ] pourquoi laisser le choix du transporteur pour le produit 2 et pas le 1 ou le 3 ?

Je dois préciser que pour ces tests, les 3 produits sont ceux de la démo. Produits standard non dématérialisés.

  • How to reproduce the issue ?

N/A

@prestonBot

This comment has been minimized.

Copy link
Collaborator Author

commented Aug 23, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: guillaumeb
  • Created at: Wed, 22 Mar 2017 11:40:56 +0100

tu pourrais te pencher là-dessus vu que tu avais accepté les PR de Dekker sur ça ?

@prestonBot

This comment has been minimized.

Copy link
Collaborator Author

commented Aug 23, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: vincentbz
  • Created at: Wed, 22 Mar 2017 13:28:31 +0100

Je vais regarder, mais ce n'est pas lié à la PR de dekker. En fait le probleme ici concerne l'incompatibilité entre produits et transporteurs. Quand certains produits n'ont que certains transporteurs et que tu as des produits qui n'ont pas les mêmes transporteurs associés, là ça merde. C'est aussi le cas en 1.6 donc, je vais vérifier, mais rien de nouveau sous les tropiques malheureusement

@prestonBot

This comment has been minimized.

Copy link
Collaborator Author

commented Aug 23, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: vincentbz
  • Created at: Tue, 9 May 2017 17:54:16 +0200

Ici ce qu'il serait bien de faire, c'est d'utiliser le split de commandes, qui existe mais ne fonctionne pas.
Le split de commandes ne se fait normalement que quand il n'y a pas de stock pour l'un des deux et qu'ils ne peuvent être livrés ensemble. Cela doit aussi être le cas si deux produits ne peuvent pas avoir de transporteur en commun.

@prestonBot

This comment has been minimized.

Copy link
Collaborator Author

commented Aug 23, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: vincentbz
  • Created at: Wed, 27 Dec 2017 11:16:13 +0100

Marion F ya un sujer rigolo qui peut t'intéresser. Le split de commandes qui est sensé marcher mais ne fonctionne plus sur un point. On peut regarder ça ensemble. Split en plusieurs commandes quand il n'y a pas de transporteurs compatibles à tous les produits, split de commandes quand les produits ne sont pas dispos en meme temps. Y a l'option pour ça. Mais ça marche pas en FO.

Cécile Dubouis c'est un sujet qui peut aussi t'intéresser je pense.

@prestonBot

This comment has been minimized.

Copy link
Collaborator Author

commented Aug 23, 2018

This comment has been migrated from the Forge. Read the original comment here.

  • Author: marion_francois
  • Created at: Thu, 28 Dec 2017 16:49:22 +0100

Le split fonctionne correctement dans le cas où les articles de ma commande ne sont pas livrés par le même transporteur.
Le calcul des frais de transport sont également bons (on additionne le prix des différents transporteurs sélectionnés)

Il y a juste ici l'affichage en front-office à revoir.
En 1.6.0.9 on me proposait les transporteurs disponibles pour chaque produit/groupe de produit, comme-ceci:

L'idée est de faire la même chose en 1.7 mais en plus sexy.

Tristan Lehot dit moi quand tu as un moment que l'on voit cela ensemble

 

@agnesdennetiere

This comment has been minimized.

Copy link
Contributor

commented Nov 5, 2018

Bonjour,

est-ce que ce point a été réglé sur une version de 1.7 ? Merci

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Nov 6, 2018

@agnesdennetiere, sorry not yet.
It should be specified by our developers.
Thanks!

@antoinemineau

This comment has been minimized.

Copy link

commented Nov 13, 2018

Hi,
any update on this @khouloudbelguith ?
This is a very big issue, I think there is no plugins that fixes this problem too...
If you have an idea on how to fix this, I am interested

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Nov 13, 2018

@agnesdennetiere, sorry not yet.
@colinegin, @marionf, what you think? this issue should be specified.
Thanks!

@alexstop82

This comment has been minimized.

Copy link

commented Jan 17, 2019

Hi,
have you got any news on this @khouloudbelguith ?

This is a very big problem

Thanks

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Jan 17, 2019

Hi @alexstop82,

Sorry not yet.
This issue is assigned to our developers.
Thanks for your patience & your understanding!

@alexstop82

This comment has been minimized.

Copy link

commented Jan 17, 2019

@agnesdennetiere

This comment has been minimized.

Copy link
Contributor

commented Feb 25, 2019

Hello,

still no news ?
It is a big problem for carrier which have an extra content (with a date selection for instance)

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Feb 25, 2019

Hi @antoinemineau,

Sorry not yet.
It should be specified by our developpers.
Thanks!

@nexinet

This comment has been minimized.

Copy link

commented Feb 28, 2019

Any news about this Bug ? or any workaround to fix it?

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Feb 28, 2019

@nexinet,

Sorry not yet.
Thanks for your understanding!
There are some major issues to solve before this one.
PrestaShop is an open source project, so it can be solved before if someone submits a pull request to solve it.

Thanks!

@nexinet

This comment has been minimized.

Copy link

commented Mar 2, 2019

Hello Kholoud this is a big bug so I think developer need to focus on it.
or give us a workaround to help that
thanks

@florine2623

This comment has been minimized.

Copy link

commented Mar 13, 2019

PS Version : 1.7.5.0

Steps to reproduce the bug :
1 - Create a carrier for Belgium
2 - Add a product only delivered in Belgium in the cart
3 - When adding my French address in the checkout process, I can’t continue (I have an error message: No carrier can deliver to this address => correct)
4 - But if I add a product deliverable in France in the same cart, I can process to checkout => which is incorrect

Thank you

@khouloudbelguith

This comment has been minimized.

Copy link
Contributor

commented Mar 13, 2019

Hi @florine2623,

Thanks for your feedback.
I have the same issue with PS1.7.5.1.
image

Thanks!

@MatShir MatShir added the FO label May 10, 2019

@colinegin colinegin referenced this issue May 16, 2019
21 of 39 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.