Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incorrect translation arguments passed in cms page form #13777

Conversation

@tomas862
Copy link
Member

commented May 13, 2019

Questions Answers
Branch? 1.7.6.x
Description? Incorrect argument positions causes whole page to crash in CMS Page Create or Edit form. Also added missing automated test for this page which would have helped to avoid the issue
Type? bug fix
Category? BO
BC breaks? no
Deprecations? no
Fixed ticket?
How to test? Just go to to page Create/Edit CMS Page - right now it is loaded.

This change is Reviewable

@tomas862 tomas862 requested a review from PrestaShop/prestashop-core-developers as a code owner May 13, 2019

@tomas862 tomas862 changed the base branch from 1.7.6.0-beta to 1.7.6.x May 13, 2019

@prestonBot prestonBot added the 1.7.6.x label May 13, 2019

@@ -154,6 +154,7 @@ public function getDataProvider()
'admin_employees_create' => ['Add new employee', 'admin_employees_create'],
'admin_cms_pages_index' => ['Cms page', 'admin_cms_pages_index'],
'admin_cms_pages_category_create' => ['Add new cms category page', 'admin_cms_pages_category_create'],
'admin_cms_pages_create' => ['Add new cms page', 'admin_cms_pages_create'],

This comment has been minimized.

Copy link
@matks

matks May 13, 2019

Contributor

❤️

@matks matks added this to the 1.7.6.0 milestone May 13, 2019

@sarahdib

This comment has been minimized.

Copy link

commented May 14, 2019

Hello @tomas862 how do we reproduce the problem ?

@sarahdib sarahdib self-assigned this May 14, 2019

@tomas862

This comment has been minimized.

Copy link
Member Author

commented May 14, 2019

Hello @tomas862 how do we reproduce the problem ?

Hi @sarahdib - you can check PrestaShop 1.7.6.x branches at go to admin-dev/index.php/improve/design/cms-pages/ . You can click "Add new page" or "edit existing one" - the whole page will go down. This fix makes sure this thing does not happen

@matks

This comment has been minimized.

Copy link
Contributor

commented May 14, 2019

@tomas862 Actually it required to enable the multishop too 😉

@matks

This comment has been minimized.

Copy link
Contributor

commented May 14, 2019

Tests fail, and it's not a random issue o_O (I restarted the build)

@tomas862

This comment has been minimized.

Copy link
Member Author

commented May 14, 2019

another sneaky bug might be - I'll check it as soon as possible ;)

->disableOriginalConstructor()
->getMock();
$contextMock->link = $linkMock;

This comment has been minimized.

Copy link
@tomas862

tomas862 May 15, 2019

Author Member

@matks it turns out that legacy tests did not had link mocked - I added it so it will now exist in the context :)

@matks
matks approved these changes May 15, 2019
@matks

This comment has been minimized.

Copy link
Contributor

commented May 15, 2019

Thank you @tomas862

@matks matks merged commit a5065bd into PrestaShop:1.7.6.x May 15, 2019

2 checks passed

PrettyCI Code formatting
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@prestonBot prestonBot added the Bug label Jun 25, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.