New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Prevent installation on old PHP versions #171

Merged
merged 3 commits into from Sep 24, 2018

Conversation

Projects
None yet
3 participants
@Quetzacoalt91
Member

Quetzacoalt91 commented Sep 13, 2018

Fixes #170

This PR fixes the syntax errors on very old versions of PHP, but prevent its installation on the concerned shops.

capture du 2018-09-13 10-43-38


This change is Reviewable

Quetzacoalt91 added some commits Sep 12, 2018

Merge pull request #169 from PrestaShop/dev
Deploying v4.2.0 of 1-click upgrade

@Quetzacoalt91 Quetzacoalt91 changed the base branch from master to dev Sep 13, 2018

@Quetzacoalt91 Quetzacoalt91 added this to the 4.3.0 milestone Sep 13, 2018

@Quetzacoalt91 Quetzacoalt91 changed the title from Prevent run on old php to Prevent installation on old PHP versions Sep 13, 2018

@Quetzacoalt91 Quetzacoalt91 merged commit 8ff30b5 into PrestaShop:dev Sep 24, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Quetzacoalt91 Quetzacoalt91 deleted the Quetzacoalt91:prevent-run-on-old-php branch Sep 24, 2018

@doekia

This comment has been minimized.

Show comment
Hide comment
@doekia

doekia Oct 19, 2018

Contributor

Je pense que vous avez complètement raté l'objectif d'un module d'upgrade. Il doit justement fonctionner en php5.2 pour permettre à quelqu'un de migrer son vieux shop puisqu'une vieille version ne fonctionne pas en php7 ou php5.6!

Contributor

doekia commented Oct 19, 2018

Je pense que vous avez complètement raté l'objectif d'un module d'upgrade. Il doit justement fonctionner en php5.2 pour permettre à quelqu'un de migrer son vieux shop puisqu'une vieille version ne fonctionne pas en php7 ou php5.6!

@eternoendless

This comment has been minimized.

Show comment
Hide comment
@eternoendless

eternoendless Oct 19, 2018

Member

Hi @doekia

Since the official language here is English, I'm taking the liberty of translating your comment to English so that others can understand it too. I used Google Translate out of lazyness, but I think it did a pretty good job:

I think you have completely missed the goal of an upgrade module. It must work in php5.2 to allow someone to migrate his old shop since an old version does not work in php7 or php5.6!

By "old shop" you mean lower than 1.6? This module is able to upgrade shops starting on 1.6 only, and 1.6 should be compatible with 5.6. However, it is possible (and it has been proved true) that shops can be upgraded to 1.7 all the way back from 1.4 in two steps, first upgrading to 1.6 using the latest available module for 1.4, then to 1.7 using the latest version of the upgrade module.

We had three main reasons for upping the minimum compatibility to 5.6:

  1. Very old PHP versions pose a security threat for merchants, so they are strongly encouraged to upgrade.
  2. Some libraries that we needed for this module are only available on PHP >=5.6
  3. We need to make sure that merchants won't upgrade their shops to 1.7 if they don't meet the minimum requirements.

I hope this provides a better insight into our choices.

Member

eternoendless commented Oct 19, 2018

Hi @doekia

Since the official language here is English, I'm taking the liberty of translating your comment to English so that others can understand it too. I used Google Translate out of lazyness, but I think it did a pretty good job:

I think you have completely missed the goal of an upgrade module. It must work in php5.2 to allow someone to migrate his old shop since an old version does not work in php7 or php5.6!

By "old shop" you mean lower than 1.6? This module is able to upgrade shops starting on 1.6 only, and 1.6 should be compatible with 5.6. However, it is possible (and it has been proved true) that shops can be upgraded to 1.7 all the way back from 1.4 in two steps, first upgrading to 1.6 using the latest available module for 1.4, then to 1.7 using the latest version of the upgrade module.

We had three main reasons for upping the minimum compatibility to 5.6:

  1. Very old PHP versions pose a security threat for merchants, so they are strongly encouraged to upgrade.
  2. Some libraries that we needed for this module are only available on PHP >=5.6
  3. We need to make sure that merchants won't upgrade their shops to 1.7 if they don't meet the minimum requirements.

I hope this provides a better insight into our choices.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment