Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Display a notice if PHP is below v7.1 #284

Merged
merged 13 commits into from Jul 3, 2019

Conversation

@Quetzacoalt91
Copy link
Member

commented Feb 27, 2019

This PRs notifies when the running PHP server reached its end of life at 2 places, but the module remains compatible with PHP v5.6.

Module configuration: Check list

capture d ecran du 2019-02-27 11-32-28

Not OK: The PHP version your server is running on is obsolete and needs to be upgraded. Learn more why or ignore.
OK: Your server is running on a supported PHP version.

Backoffice dashboard

capture d ecran du 2019-02-27 11-32-54

<head>PHP Version notice

<body>The PHP version your shop is running on is insecure.
It reached its end-of-life, which means it won't get security updates anymore and projects will stop supporting it.

Upgrading will keep your shop secured and performant.

<button>Learn more about PHP and upgrading
@Quetzacoalt91

This comment has been minimized.

Copy link
Member Author

commented Feb 27, 2019

@LouiseBonnard, @eternoendless & @ttoine, you may want to review the wording before going further?

@Quetzacoalt91 Quetzacoalt91 added this to the 4.7.0 milestone Feb 27, 2019

@Quetzacoalt91 Quetzacoalt91 force-pushed the Quetzacoalt91:php56-warn branch from e813d28 to c8ad427 Feb 27, 2019

@Quetzacoalt91

This comment has been minimized.

Copy link
Member Author

commented Apr 1, 2019

The content to be linked with this feature is under discussion and not ready yet. Closing as it cannot be shipped with the next version of the module.

@Quetzacoalt91

This comment has been minimized.

Copy link
Member Author

commented Jun 11, 2019

@Quetzacoalt91 Quetzacoalt91 changed the title Display a notice if PHP is below v7.0.0 Display a notice if PHP is below v7.1 Jun 11, 2019

@Quetzacoalt91 Quetzacoalt91 force-pushed the Quetzacoalt91:php56-warn branch from 05b9d20 to 8aa2ac1 Jun 11, 2019

@Quetzacoalt91 Quetzacoalt91 modified the milestones: 4.7.0, 4.9.0 Jun 11, 2019

Show resolved Hide resolved autoupgrade.php Outdated

@Quetzacoalt91 Quetzacoalt91 force-pushed the Quetzacoalt91:php56-warn branch from a8280c4 to 7fb302c Jun 12, 2019

@matks

This comment has been minimized.

Copy link

commented Jun 12, 2019

Shall we introduce something similar in PS installer ?

@Quetzacoalt91

This comment has been minimized.

Copy link
Member Author

commented Jun 12, 2019

That was indeed suggested.

@Quetzacoalt91 Quetzacoalt91 force-pushed the Quetzacoalt91:php56-warn branch from e3c5cbb to 021d86e Jun 14, 2019

Update classes/UpgradeSelfCheck.php
Co-Authored-By: GoT <PierreRambaud@users.noreply.github.com>
Show resolved Hide resolved autoupgrade.php Outdated
Show resolved Hide resolved autoupgrade.php Outdated

@sarahdib sarahdib added QA approved and removed Waiting for QA labels Jul 3, 2019

@Quetzacoalt91 Quetzacoalt91 merged commit fd9f7a1 into PrestaShop:dev Jul 3, 2019

2 checks passed

PrettyCI Code formatting
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Quetzacoalt91 Quetzacoalt91 deleted the Quetzacoalt91:php56-warn branch Jul 3, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.