Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
A plugin for interacting with tunnlr on both unix and windows. Uses the net::ssh gem
Ruby
branch: master

This branch is 2 commits ahead, 5 commits behind mmangino:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
bin
lib
rails
test
.gitignore
MIT-LICENSE
README
Rakefile
init.rb
install.rb
tunnlr.yml
tunnlr_connector.gemspec
uninstall.rb

README

TunnlrConnector
===============

TunnlrConnector is a plugin to make connecting to the Tunnlr service easy an painless.

It requires the net::ssh v2 plugin. To install, execute

gem install --source http://gems.jamisbuck.org net-ssh

To run autoconfigure, it also requires the highline gem which is installed as part of capistrano.

Installation
============

Rails 2
-------

Add the gem to config/development.rb

    config.gem 'tunnlr_connector', :lib => false

And add the following to the end of Rakefile

    begin
      require 'tunnlr'
      Tunnlr.load_tasks if defined?(Tunnlr)
    rescue LoadError => loaderror
      $stderr.puts %{Couldn't load tunnlr}
    end
    
Rails 3
-------

Add the gem to the development group of your Gemfile

    gem 'tunnlr_connector', :require => "tunnlr"
    
That's it!

Example
=======

To autoconfigure, run

  rake tunnlr:configure

and enter the email address and password associated with your tunnlr account.

To create a tunnel, run

  rake tunnlr:start
  
  
Questions or problems? Contact support@tunnlr.com



Copyright (c) 2008 Elevated Rails, released under the MIT license
Something went wrong with that request. Please try again.