Skip to content
Browse files

Bump minimum Python version to 2.6 for multiprocessing support

Signed-off-by: James McCoy <jamessan@users.sourceforge.net>
  • Loading branch information...
1 parent 232aa86 commit 83f872fa123994a15c8996dc25934b3055a51715 @jamessan jamessan committed Sep 1, 2012
Showing with 13 additions and 11 deletions.
  1. +1 −1 INSTALL
  2. +1 −1 RELNOTES
  3. +1 −1 docs/PLUGIN_TUTORIAL.rst
  4. +2 −2 scripts/supybot
  5. +2 −2 scripts/supybot-plugin-create
  6. +2 −2 scripts/supybot-wizard
  7. +4 −2 setup.py
View
2 INSTALL
@@ -1,6 +1,6 @@
Common
- First things first: Supybot *requires* at least Python 2.4. There
+ First things first: Supybot *requires* at least Python 2.6. There
ain't no getting around it. You can get it from http://www.python.org/.
Recommended Software
View
2 RELNOTES
@@ -1,6 +1,6 @@
Version 0.83.5
-The minimum supported Python version has been bumped to 2.4.
+The minimum supported Python version has been bumped to 2.6.
utils.str.perlVariableSubstitute is deprecated in favor of using Python's
string.Template directly. perlVariableSubstitute will be removed in a future
View
2 docs/PLUGIN_TUTORIAL.rst
@@ -325,7 +325,7 @@ information on using wrap check out the wrap tutorial (The astute Python
programmer may note that this is very much like a decorator, and that's
precisely what it is. However, we developed this before decorators existed and
haven't changed the syntax due to our earlier requirement to stay compatible
-with Python 2.3. As we now require Python 2.4 or greater, this may eventually
+with Python 2.3. As we now require Python 2.6 or greater, this may eventually
change to support work via decorators.)
Now let's create a command with some arguments and see how we use those in our
View
4 scripts/supybot
@@ -44,8 +44,8 @@ import shutil
import signal
import cStringIO as StringIO
-if sys.version_info < (2, 4, 0):
- sys.stderr.write('This program requires Python >= 2.4.0')
+if sys.version_info < (2, 6, 0):
+ sys.stderr.write('This program requires Python >= 2.6.0')
sys.stderr.write(os.linesep)
sys.exit(-1)
View
4 scripts/supybot-plugin-create
@@ -43,8 +43,8 @@ def error(s):
sys.stderr.write(os.linesep)
sys.exit(-1)
-if sys.version_info < (2, 4, 0):
- error('This script requires Python 2.4 or newer.')
+if sys.version_info < (2, 6, 0):
+ error('This script requires Python 2.6 or newer.')
import supybot.conf as conf
from supybot.questions import *
View
4 scripts/supybot-wizard
@@ -39,8 +39,8 @@ def error(s):
sys.stderr.write(os.linesep)
sys.exit(-1)
-if sys.version_info < (2, 4, 0):
- error('This program requires Python >= 2.4.0')
+if sys.version_info < (2, 6, 0):
+ error('This program requires Python >= 2.6.0')
import supybot
View
6 setup.py
@@ -30,10 +30,12 @@
# POSSIBILITY OF SUCH DAMAGE.
###
+import os
import sys
-if sys.version_info < (2, 4, 0):
- sys.stderr.write("Supybot requires Python 2.4 or newer.\n")
+if sys.version_info < (2, 6, 0):
+ sys.stderr.write("Supybot requires Python 2.6 or newer.")
+ sys.stderr.write(os.linesep)
sys.exit(-1)
import textwrap

0 comments on commit 83f872f

Please sign in to comment.
Something went wrong with that request. Please try again.