timestamp on www doesn't work any more #530

Closed
UmpPCPL opened this Issue Dec 6, 2012 · 5 comments

2 participants

@UmpPCPL

Hi

There were some changes on OSRM router side and web frontend doesn't display
data timestamp any more.
I guess allowed format of /timestamp query has changed.

On September simply query worked
http://router.project-osrm.org/timestamp

and returned
{"version":0.3,"status":0,"timestamp":"UMP.auto:06.12","transactionId":"OSRM Routing Engine JSON timestamp (v0.3)"}

Now it returns
"400 Bad Request
Input seems to be malformed close to position 0

/timestamp
"

Correct syntax now is
router.project-osrm.org/timestamp?&jsonp=JSONP

Return:
JSONP({"version":0.3,"status":0,"timestamp":"121205 08:00Z","transactionId":"OSRM Routing Engine JSON timestamp (v0.3)"}

(Missing closing bracket !!!)

Should be easy to fix :-)

Michal

@DennisOSRM DennisOSRM pushed a commit that referenced this issue Dec 6, 2012
DennisOSRM fixes issue #530 86a5bba
@UmpPCPL

Dennis in my opinion it is not fix for this issue.
In response for timestamp request we still have syntax error. (Missing closing bracket)
and your site http://map.project-osrm.org/ does not display timestamp
in configuration dialog.

@DennisOSRM DennisOSRM pushed a commit that referenced this issue Dec 11, 2012
Dennis Luxen fixes regression in first fix to issue #530 411d433
@DennisOSRM
Project OSRM member

Please try again with the latest fixes.

@UmpPCPL

Unfortunately it doesn't work for me ( "develop" branch ).

This is my test router url.
http://osrm1.ump.waw.pl/OSRMauto/timestamp?jsonp=TEST

Still closing bracket is missing.

@DennisOSRM
Project OSRM member

Did you rebuild the binaries from the latest source in develop. The code there looks unsuspicious and it works on a local installation.

@UmpPCPL

It works as expected. Very sorry for wasting your time on this issue.

@UmpPCPL UmpPCPL closed this Dec 19, 2012
@Zhdanovich Zhdanovich pushed a commit to Zhdanovich/Project-OSRM that referenced this issue Jul 20, 2014
DennisOSRM fixes issue #530 3dec352
@Zhdanovich Zhdanovich pushed a commit to Zhdanovich/Project-OSRM that referenced this issue Jul 20, 2014
Dennis Luxen fixes regression in first fix to issue #530 b3e6caf
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment