Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

osrm-prepare exists with 'should not happen' #578

Closed
emiltin opened this Issue · 1 comment

2 participants

@emiltin
Collaborator

i'm getting this when processing denmark.pbf from geofabrik using 43bb53e.

extractor runs ok, but osrm-prepare aborts:

[info createHierarchy.cpp:77] Using restrictions from file: denmark.osrm.restrictions
[info createHierarchy.cpp:120] Parsing speedprofile from ../profiles/bicycle.lua
[info ./Util/GraphLoader.h:191] Graph loaded ok and has 2856978 edges
[info createHierarchy.cpp:141] 418 restrictions, 564 bollard nodes, 2807 traffic lights
[info createHierarchy.cpp:150] Generating edge-expanded graph representation
[info Contractor/EdgeBasedGraphFactory.cpp:172] Identifying small components
. 10% . 20% . 30% . 40% . 50% . 60% . 70% . 80% . 90% . 100%
[info Contractor/EdgeBasedGraphFactory.cpp:226] identified: 9649 many components
[error Contractor/EdgeBasedGraphFactory.cpp:378] should not happen

@DennisOSRM
Owner

Fixed.

@DennisOSRM DennisOSRM closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.