New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Nami update 1.4.2 to 1.9.8 #304

Open
melkerj opened this Issue Sep 10, 2018 · 7 comments

Comments

Projects
None yet
2 participants
@melkerj
Copy link

melkerj commented Sep 10, 2018

Hi!

I thought it was about time to update some of my websites to more current versions of project nami.
One of the older ones ran 1.4.2 just fine and after updating to 1.9.8 it didn't anymore.
No surprise there but if anyone knows what the major differences are between the two versions that would be very helpful so I won't have to go through all the updates one by one looking for what might be causing the problem.

Note: local it runs just fine. After deploying to Azure the issue occurs.

Ss in swedish...

githubticket

@patrickebates

This comment has been minimized.

Copy link
Member

patrickebates commented Sep 10, 2018

What version of PHP is that site running? That's the first place I would look. I would recommend using 7.1 with the current version of PN.

@melkerj

This comment has been minimized.

Copy link
Author

melkerj commented Sep 10, 2018

PHP 5.3.x
Another website I updated last week were from 1.9.6 to 1.9.8 and is also running php 5.3.x and that worked out.

@patrickebates

This comment has been minimized.

Copy link
Member

patrickebates commented Sep 10, 2018

Are these running in Web Apps or on a VM? Asking for clarification as PHP 5.6 should be the oldest available on Web Apps.

@melkerj

This comment has been minimized.

Copy link
Author

melkerj commented Sep 10, 2018

They are all running with "App Services" that Azure provides in their portal

@patrickebates

This comment has been minimized.

Copy link
Member

patrickebates commented Sep 10, 2018

I would suggest checking the error logs for the full details. Might be in eventlog.xml or the PHP error log.

@melkerj

This comment has been minimized.

Copy link
Author

melkerj commented Sep 10, 2018

Hmm azure says PHP 5.6 and in Aptana Studio 3 on my local machine it says PHP 5.3.
And this is the version pushed to live.

vabphpversion

vabphpversionlocal

@patrickebates

This comment has been minimized.

Copy link
Member

patrickebates commented Sep 10, 2018

Is it possible this particular site has some PHP modules included which might be incompatible with the different PHP version?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment