Mmaps crash #409

Closed
Walkum opened this Issue Apr 18, 2012 · 19 comments

Comments

Projects
None yet
7 participants

Walkum commented Apr 18, 2012

I'm Retarded

Branch: mmaps2_beta
OS: Linux
Tested with maps / vmaps of a 4.0.6a and of a 4.2.0.

Mmaps turned on:
When you enter in combat with a mob, server crash instantly (in a 90% of maps), and on other maps, like gilneas for example, when you enter in combat, the mob is quiet in his position and don't move.

Mmaps turned off:
Server works better, but some mobs (3 or 4 on Netherstorm, and 2 or 3 in Frondavil, only that I can tested) when you enter in combat with they, server crashes.

BT simple: http://pastebin.com/JfsmUhhj
BT full: http://pastebin.com/LagXS37p

Contributor

Sovak commented Apr 18, 2012

Dont you have backtrace ?

Walkum commented Apr 18, 2012

I'm Retarded

Contributor

thomas33 commented Apr 18, 2012

lol -_-

Walkum commented Apr 18, 2012

I'm Retarded

Contributor

thomas33 commented Apr 18, 2012

this crash is when you pull any mob?

Walkum commented Apr 18, 2012

I'm Retarded

Contributor

thomas33 commented Apr 18, 2012

but we still need backtrace..

Walkum commented Apr 18, 2012

I'm Retarded

Contributor

thomas33 commented Apr 18, 2012

omg read in wiki -_-

Walkum commented Apr 18, 2012

I'm Retarded

Contributor

Bootz commented Apr 19, 2012

hmmmz... sry i can not confirm this but am inclining to deny this one, just sat for 45 minutes killing handsfull of mobs in differ areas...

Walkum commented Apr 19, 2012

I'm Retarded

Contributor

Raydeon commented Apr 19, 2012

Have you cleared your client cache since you changed to mmaps? I tested tons of npcs and no crash whatsoever

Walkum commented Apr 19, 2012

I'm Retarded

Contributor

Bootz commented Apr 19, 2012

no crashes here, idky you have them that badly.
sounds more like ur having creature issues rather than map pathing.

Walkum commented Apr 19, 2012

I'm Retarded

Contributor

Bootz commented Apr 19, 2012

you cant use old maps/vmaps with new system and expect it to correctly work.
all extractors magic#'s have changed, and core&collision changes need the new maps/vmaps
and extracted mmaps for it to work "the right way"

Walkum commented Apr 19, 2012

I'm Retarded

olivete commented Apr 30, 2012

Walkum could you confirm if this error remains? I have got the very same erros and I am using the enGB maps too. Thanks alot!

@SkyFire SkyFire closed this May 4, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment