Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Unable to compile with RPi/ #47

ug2215 opened this Issue · 1 comment

2 participants


Trying to compile for RaspberryPi via Fedora 20 fails with:

configure: error: C compiler cannot create executables

It points me to config.log which ends with:

/* confdefs.h */
#define PACKAGE_NAME "lockdev"
#define PACKAGE_TARNAME "lockdev"
#define PACKAGE_VERSION "1.0.4"
#define PACKAGE_STRING "lockdev 1.0.4"
#define PACKAGE_URL ""
#define PACKAGE "lockdev"
#define VERSION "1.0.4"
#define RELEASE_DATE_S "19 May 2012"
#define RELEASE_DATE 1337403600

configure: exit 77

I have installed lockdev-devel-1.0.4-0.11.20111007git.fc20.x86_64

I am not sure what to do because lockdev seems up-to-date.


You best compile directly on the Pi itself if you don't want to be bothered by these dependencies. You need lockdev for the target if you're cross compiling, not for the host that builds it. So you need lockdev in your Pi's toolchain.

@opdenkamp opdenkamp closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.