Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

require python 3.8.1+ #1741

Merged
merged 1 commit into from Nov 18, 2022
Merged

require python 3.8.1+ #1741

merged 1 commit into from Nov 18, 2022

Conversation

asottile
Copy link
Member

@asottile asottile commented Nov 18, 2022

a few months early, but the old versions continue to work fine

3.8.0 is ancient, and excluded due to broken importlib.metadata as well

@asottile asottile merged commit b87034d into main Nov 18, 2022
10 checks passed
@asottile asottile deleted the drop-py37 branch November 18, 2022 16:37
@asottile asottile added this to the 6.0.0 milestone Nov 23, 2022
br3ndonland added a commit to br3ndonland/inboard that referenced this pull request Nov 26, 2022
Flake8 6 requires `python>=3.8.1`, so the version constraint will be
updated accordingly. Apparently `python==3.8.0` had an issue with
`importlib.metadata`.

PyCQA/flake8#1741
https://flake8.pycqa.org/en/latest/release-notes/6.0.0.html
br3ndonland added a commit to br3ndonland/fastenv that referenced this pull request Nov 26, 2022
Flake8 6 requires `python>=3.8.1`, so the version constraint will be
updated accordingly. Apparently `python==3.8.0` had an issue with
`importlib.metadata`.

PyCQA/flake8#1741
https://flake8.pycqa.org/en/latest/release-notes/6.0.0.html
br3ndonland added a commit to br3ndonland/fastenv that referenced this pull request Nov 26, 2022
Flake8 6 requires `python>=3.8.1`, so the version constraint will be
updated accordingly. Apparently `python==3.8.0` had an issue with
`importlib.metadata`.

PyCQA/flake8#1741
https://flake8.pycqa.org/en/latest/release-notes/6.0.0.html
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

1 participant