Drop support for Python 2.3 and 2.4 #78

florentx opened this Issue Jun 13, 2012 · 3 comments


None yet
3 participants

florentx commented Jun 13, 2012

The final security releases of 2.3 and 2.4 were issued in 2008.
Even Python 2.5 reached end of maintenance period in 2011.

There's little interest in maintaining compatibility with these historical versions.
I do not have a test environment for these versions anymore.

I know there are already some incompatibilities in the trunk: sorted was added in Python 2.4 and try ... except ... finally is not supported before Python 2.5.

I propose to officially require Python >= 2.5, for upcoming release 1.3.

Personally I agree that 2.5 is the oldest supported version.. while 2.5 is on its last leg support wise its still heavily used. In two of the projects I'm part of, we currently have been doing 2.5+ support and will probably move to 2.6+ next year if we come across something that forces us to make the change.. thankfully simpleJSON picks up the 2.5 slack. To target the widest possible audience while requiring barely any extra work to ensure 2.5+ compatibility I think is a fair thing to do for everyone. If they need pre 2.5 they can just use a previous build/tag of pep8.

florentx added a commit that referenced this issue Jun 14, 2012


florentx commented Jun 15, 2012

Released version 1.3 requires Python >= 2.5

@florentx florentx closed this Jun 15, 2012


jcrocholl commented Jun 15, 2012

I agree, thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment