Just switching the #!/usr/bin/python to #!/usr/bin/env python so that this works with virtualenv. #26

Merged
merged 1 commit into from Apr 6, 2012

Conversation

Projects
None yet
3 participants
Contributor

slacy commented Mar 2, 2011

Make pep8 work right with virtualenv.

@slacy slacy Use /usr/bin/env python instead of straight /usr/bin/python
This change makes the pep8 executable function properly when running under a
virtualenv or zc.buildout environment, which will have a special version of
python on the path that internally changes its PYTHONPATH to include special
libraries and modules.
21677bd

Just a note, but using setuptools or pip to install this should update the crashbang in all installed files. This won't affect things if you're running pep8 itself directly, but just something to keep in mind.

Contributor

florentx commented Mar 26, 2012

Thank you for the patch.
Fixed in 0.7.0.

florentx merged commit 21677bd into PyCQA:master Apr 6, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment