New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop pypy3 (temporarily) #223

Merged
merged 3 commits into from Dec 2, 2016

Conversation

Projects
None yet
2 participants
@Nurdok
Copy link
Member

Nurdok commented Nov 27, 2016

PyPy3 currently only implements the equivalent of CPython 3.2, which we don't support. Pip has also dropped support for PyPy3, resulting in the following build error:

/home/travis/virtualenv/pypy3-2.4.0/site-packages/virtualenv_support/pip-9.0.1-py2.py3-none-any.whl/pip/_vendor/pkg_resources/__init__.py:83: UserWarning: Support for Python 3.0-3.2 has been dropped. Future versions will fail here.
pip requires Python '>=2.6,!=3.0.*,!=3.1.*,!=3.2.*' but the running Python is 3.2.5

Support for PyPy3 will be restored when it is supported by Pip, and when it will implement a newer equivalent version for CPython (3.3 or higher).

@Nurdok Nurdok self-assigned this Nov 27, 2016

@Nurdok Nurdok merged commit 511b2c3 into PyCQA:master Dec 2, 2016

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Nurdok Nurdok deleted the Nurdok:feature/drop-pypy3 branch Dec 2, 2016

@peterjc

This comment has been minimized.

Copy link

peterjc commented Apr 19, 2017

I noticed this issue noted in the v2.0.0 release notes - but PyPy3.5 v5.7 is out now and supports the equivalent of CPython 3.5

This isn't available on TravisCI by default yet, but that can be worked around - see travis-ci/travis-ci#6727

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment