New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Declare Python 3.6 support #270

Merged
merged 1 commit into from Jul 8, 2017

Conversation

Projects
None yet
2 participants
@jonafato
Copy link
Contributor

jonafato commented Jul 5, 2017

  • Enabled tests in tox.ini and .travis.yml
  • Declare support for 3.6 in README.rst and docs/release_notes.rst

Thanks for submitting a PR!

Please make sure to check for the following items:

  • Add unit tests and integration tests where applicable.
    If you've added a error code or changed an error code behavior,
    you should probably add or change a test case file under tests/test_cases/ and add
    it to the list under tests/test_definitions.py.
    If you've added or changed a command line option,
    you should probably add or change a test in tests/test_integration.py.
  • Add a line to the release notes (docs/release_notes.rst) under "Current Development Version".
    Make sure to include the PR number after you open and get one.

Please don't get discouraged as it may take a while to get a review.

@jonafato jonafato force-pushed the jonafato:python3.6 branch from 8e8aa59 to a3a23d8 Jul 5, 2017

@jonafato

This comment has been minimized.

Copy link
Contributor

jonafato commented Jul 7, 2017

This error when building the docs is unrelated to my change and appears to be isolated to sphinx==1.6.3. When testing locally using 1.6.2 or sphinx master, the docs build without issue. Once the next version of sphinx is released, the failure should go away on its own.

@Nurdok

This comment has been minimized.

Copy link
Member

Nurdok commented Jul 7, 2017

In that case, can you pin down the Sphinx version in the docs requirements file? That way, the build will pass and I could merge this.

Declare Python 3.6 support
- Enabled tests in ``tox.ini`` and ``.travis.yml``
- Declare support for 3.6 in ``README.rst`` and ``docs/release_notes.rst``

@jonafato jonafato force-pushed the jonafato:python3.6 branch from a3a23d8 to b7cc70a Jul 7, 2017

@jonafato

This comment has been minimized.

Copy link
Contributor

jonafato commented Jul 7, 2017

@Nurdok sphinx pinned, travis passing.

@Nurdok

Nurdok approved these changes Jul 8, 2017

@Nurdok Nurdok merged commit 6510a2b into PyCQA:master Jul 8, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@Nurdok

This comment has been minimized.

Copy link
Member

Nurdok commented Jul 8, 2017

@jonafato Merged! Thanks for taking the time to do this and to investigate the Sphinx failure.

@jonafato jonafato deleted the jonafato:python3.6 branch Jul 8, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment