Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop support for Python 3.4 and remove unsupported Python versions leftovers #402

Merged

Conversation

@tjanez
Copy link
Contributor

tjanez commented Aug 28, 2019

This should remove some leftovers and make the project better prepared for the upcoming Python 3.8.

tjanez added 4 commits Aug 28, 2019
PyPy support was removed in version 4.0.0.
Python 2.7 support was removed in version 4.0.0, and older Python 2
versions long before that.
Python 3.4 has reached end-of-life and has been retired in Mar 2019:
https://www.python.org/dev/peps/pep-0429/.
@tjanez tjanez force-pushed the tjanez:remove-unsupported-python-versions-leftovers branch from 7fb0a9e to cd4a5a3 Aug 28, 2019
@Nurdok
Nurdok approved these changes Sep 20, 2019
@Nurdok Nurdok merged commit c20721b into PyCQA:master Sep 20, 2019
2 checks passed
2 checks passed
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@Nurdok

This comment has been minimized.

Copy link
Member

Nurdok commented Sep 20, 2019

Thanks so much for doing this, @tjanez!

@tjanez

This comment has been minimized.

Copy link
Contributor Author

tjanez commented Sep 20, 2019

Thanks so much for doing this, @tjanez!

Sure, no problem. If you like such project infrastructure improvements, I can continue submitting PRs 🙂.

@tjanez tjanez deleted the tjanez:remove-unsupported-python-versions-leftovers branch Sep 26, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.