Skip to content
PyQwt is a set of Python bindings for the Qwt class library which contains widgets for scientific and engineering applications (GPL, Software Development, Libraries, Scientific/Engineering, Python Modules).
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
Doc Add target for python configure.py -h Jan 24, 2005
configure
examples Simplify the adaptation to the new int/enum type checking of SIP-4.2. Feb 22, 2005
iqt
junk
numpy
pyqt_distutils Fix exception message. Dec 21, 2004
qwt
sip
.cvsignore
ANNOUNCEMENT-3.6.TXT
ANNOUNCEMENT-3.7.TXT Tweak packaging Jul 6, 2003
ANNOUNCEMENT-3.8.TXT One more typo... Nov 26, 2003
ANNOUNCEMENT-3.9.TXT Prepare next release PyQwt-4.0 Apr 18, 2004
ANNOUNCEMENT-4.0.TXT Minor edit: MacOS/X Jun 6, 2004
ANNOUNCEMENT-4.1.TXT Final tweak Nov 21, 2004
AUTHORS
COPYING Initial import into CVS Jun 15, 2003
COPYING.PyQwt Less free license Oct 5, 2003
DIFFER
INSTALL
MANIFEST.cvs Packaging for PyQwt-3.8rc0 Nov 2, 2003
MANIFEST.in Distribute Qwt-4.2.0 with PyQwt-4.2. Jan 25, 2005
Makefile Sync with Qwt-20050129 and fix a few typos. Jan 30, 2005
PATCHER
PKG-INFO Prepare for PyQwt-4.0 Jun 5, 2004
PyQwt.spec Do not remove the links to test the examples, since they are not crea… Jan 9, 2005
README Prepare the release of PyQwt-4.1. Oct 10, 2004
README.CVS Documentation tweaks Jun 18, 2003
README.NOTES Sync with Qwt-2003-07-14 and packaging Jul 14, 2003
README.Windows
REGISTRATION.SF
THANKS
patches.py
setup.cfg Add setup.cfg to repository. Jan 9, 2005
setup.py
setup_cfg_nt
setup_cfg_posix Fix typo. Oct 22, 2004
untabify.py
win-pyqt.bat By default Python-2.3 and PyQt/sip-3.8 Oct 5, 2003
win-sip.bat By default Python-2.3 and PyQt/sip-3.8 Oct 5, 2003

README

PyQwt: Python bindings for Qwt (Qt Widgets for Technical applications)

License: GPL with exceptions for use with non-GPL'ed releases of
         Qt, PyQt and sip (see the file COPYING.p).

Almost all the functionality of the Qwt library is implemented: feel free
to request missing features.

PyQwt is being developed on Mandrake, SuSE, Linux-From-Scratch and
Win4Lin/Windows-98 with:

Python-2.2      http://www.python.org
Python-2.3      http://www.python.org
Numeric-23.5    http://sourceforge.net/projects/numpy
numarray-1.1    http://www.stsci.edu/resources/software_hardware/numarray
Qwt-4.2.0       http://qwt.sourceforge.net
Qt-3.3.3        http://www.trolltech.com
Qt-2.3.1        http://www.trolltech.com
Qt-2.3.0-NC     http://www.trolltech.com
sip-3.11.1      http://www.river-bank.demon.co.uk/download/sip
sip-4.1.1       http://www.river-bank.demon.co.uk/download/sip
PyQt-3.13       http://www.river-bank.demon.co.uk/download/pyqt

This version of PyQwt requires:
1. Python -2.1, -2.2, 2.3, or 2.4
1. PyQt -3.10, -3.11, -3.12, or -3.13
2. sip -3.10, -3.11, -4.0 or -4.1
3. Qt-2.3, -3.0, -3.1, -3.2, or -3.3


INSTALLATION

See Doc/html/pyqwt/index.html or the INSTALL file for a quick start.

You can’t perform that action at this time.