Skip to content
Fetching contributors…
Cannot retrieve contributors at this time
64 lines (52 sloc) 2.47 KB
2.0 (unreleased)
------------------
- New version 2 API.
- Old version 1 API is supported for backward compatibility.
- Convert repository to Git (from Mercurial).
- Repository is now part of the Pylons project.
(https://github.com/Pylons/SQLAHelper).
1.0 (2011-12-25)
----------------
- Add ``set_base()`` function and unit test.
- Change all remaining references to pyramid_sqla to sqlahelper.
- Delete demo application, which was for an old version of Pyramid.
1.0b1 (2011-03-11)
------------------
- Remove engine-creation features from ``add_engine()``. It was getting too
complex to document all the permutations. You'll have to create the engine
yourself and pass it to ``add_engine``.
Repository SQLAHelper created
------------------------------
- Clone repository 'SQLAHelper' from 'pyramid_sqla'.
- Delete all non-SQLAlchemy code and docs; they've moved to the Akhet package.
- Rename ``pyramid_sqla`` to ``sqlahelper`` and change it from a package to a
module.
- Move pyramid_sqla/tests/test.py to tests.py.
pylons_sqla-1.0rc2 (2010-02-20, never released)
-----------------------------------------------
- ``add_static_route`` is now a Pyramid config method if you call the new
``includeme`` function. This is used in the application template.
- Add ``pyramid_sqla`` as a dependency in the application template.
- Delete websetup.py. Console scripts are more flexible than "paster
setup-app".
- Fix but that may have prevented create_db.py from finding the INI stanza.
- 100% test coverage contributed by Chris McDonough.
- Delete unneeded development code in static.py.
- Set Mako's 'strict_undefined' option in the application template.
pyramid_sqla-1.0rc1 (2010-01-26)
---------------------------------
- 'pyramid_sqla' application template supports commit veto feature in
repoze.tm2 1.0b1.
- Add production.ini to application template.
- Delete stray files in application template that were accidentally included.
pyramid_sqla-0.2 (2011-01-19)
------------------------------
- Pyramid 1.0a10 spins off view handler support to 'pyramid_handlers' package.
- 'pyramid_sqla' application template depends on Pyramid>=1.0a10.
pyramid_sqla-0.1 (2011-01-12)
------------------------------
- Initial release.
- Warning: a change in Pyramid 1.0a10 broke applications created using the
this version's application template. To run existing applications under Pyramid
1.0a10 and later, add a 'pyramid_handlers' dependency to the ``requires``
list in setup.py and reinstall the application.
Something went wrong with that request. Please try again.