Permalink
Browse files

initial work to remove py2 from the codebase

  • Loading branch information...
mmerickel committed Oct 31, 2018
1 parent 7429fcb commit 6b0e4625da2c53a1e3fdb4857fc7c6ba6ce562cf
@@ -4,20 +4,16 @@ sudo: false
matrix:
include:
- python: 2.7
env: TOXENV=py27
- python: 3.4
env: TOXENV=py34
- python: 3.5
env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
- python: pypy
env: TOXENV=pypy
- python: pypy3
env: TOXENV=pypy3
- python: 3.6
env: TOXENV=py2-cover,py3-cover,coverage
env: TOXENV=py36-cover,coverage
- python: 3.5
env: TOXENV=docs
- python: 3.6
@@ -8,8 +8,6 @@ environment:
TOXENV: "py35"
- PYTHON: "C:\\Python34"
TOXENV: "py34"
- PYTHON: "C:\\Python27"
TOXENV: "py27"
cache:
- '%LOCALAPPDATA%\pip\Cache'
@@ -69,7 +69,6 @@ def readfile(name):
"Development Status :: 6 - Mature",
"Intended Audience :: Developers",
"Programming Language :: Python",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
@@ -96,13 +95,9 @@ def readfile(name):
package_dir={'': 'src'},
include_package_data=True,
zip_safe=False,
python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
python_requires='>=3.4',
install_requires=install_requires,
extras_require={
':python_version<"3.2"': ['repoze.lru >= 0.4'],
'testing': testing_extras,
'docs': docs_extras,
},
extras_require={'testing': testing_extras, 'docs': docs_extras},
tests_require=tests_require,
test_suite="tests",
entry_points="""\
Oops, something went wrong.

0 comments on commit 6b0e462

Please sign in to comment.