Permalink
Browse files

- The ``pyramid.paster.PyramidTemplate`` API was removed. It had been

  deprecated since Pyramid 1.1 and issued a warning on import.  If your code
  depended on this, adjust your code to import
  ``pyramid.scaffolds.PyramidTemplate`` instead.
  • Loading branch information...
1 parent deaf45b commit b274d051847299a7dc52781fbc3ce0f61070138d @mcdonc mcdonc committed Sep 9, 2012
Showing with 5 additions and 10 deletions.
  1. +5 −0 CHANGES.txt
  2. +0 −10 pyramid/paster.py
View
@@ -187,6 +187,11 @@ Backwards Incompatibilities
since Pyramid 1.0 and printed a deprecation warning upon its use. Use
``pyramid.config`` instead.
+- The ``pyramid.paster.PyramidTemplate`` API was removed. It had been
+ deprecated since Pyramid 1.1 and issued a warning on import. If your code
+ depended on this, adjust your code to import
+ ``pyramid.scaffolds.PyramidTemplate`` instead.
+
Dependencies
------------
View
@@ -1,7 +1,5 @@
import os
-import zope.deprecation
-
from paste.deploy import (
loadapp,
appconfig,
@@ -10,14 +8,6 @@
from pyramid.compat import configparser
from logging.config import fileConfig
from pyramid.scripting import prepare
-from pyramid.scaffolds import PyramidTemplate # bw compat
-
-PyramidTemplate = PyramidTemplate # pyflakes
-
-zope.deprecation.deprecated(
- 'PyramidTemplate', ('pyramid.paster.PyramidTemplate was moved to '
- 'pyramid.scaffolds.PyramidTemplate in Pyramid 1.1'),
-)
def get_app(config_uri, name=None, loadapp=loadapp):
""" Return the WSGI application named ``name`` in the PasteDeploy

0 comments on commit b274d05

Please sign in to comment.