Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

requires more pins, cant test 2.4 anymore

  • Loading branch information...
commit ff0cce43bbed92c582ec59b2876249c15413a459 1 parent 1bcff07
Chris McDonough mcdonc authored
Showing with 8 additions and 19 deletions.
  1. +8 −19 tox.ini
27 tox.ini
View
@@ -1,6 +1,9 @@
[tox]
envlist =
- py24,py25,py26,py27,pypy,jython,cover
+ py25,py26,py27,pypy,jython,cover
+
+# this code actually works under py2.4 too but tox and virtualenv have moved on
+# and no longer support it, so we don't test it anymore.
[testenv]
commands =
@@ -16,24 +19,6 @@ deps =
WebTest<=1.2.99
zope.configuration<3.8.0
-[testenv:py24]
-commands =
- python setup.py test -q
-deps =
- Sphinx
- repoze.sphinx.autointerface
- virtualenv
- PasteDeploy<1.5
- Chameleon<1.4
- WebOb<=1.0.99
- WebTest<=1.2.99
- zope.configuration<3.8.0
- zope.schema<4.0.0
- simplejson<2.1.0
- docutils<0.9
- Mako<0.7.0
- repoze.lru<0.4
-
[testenv:py25]
commands =
python setup.py test -q
@@ -47,6 +32,8 @@ deps =
WebTest<=1.2.99
zope.configuration<3.8.0
zope.schema<4.0.0
+ zope.interface<4.0.0
+ zope.component<4.0.0
[testenv:jython]
commands =
@@ -62,6 +49,8 @@ deps =
WebTest<=1.2.99
zope.configuration<3.8.0
zope.schema<4.0.0
+ zope.interface<4.0.0
+ zope.component<4.0.0
[testenv:cover]
basepython =
Please sign in to comment.
Something went wrong with that request. Please try again.