Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

depend on zope.configuration 3.8.0dev+ and bump our version to 0.8dev

  • Loading branch information...
commit 8051e0457803974213bf934fd98a51723f5083a9 1 parent 8333bb0
Chris McDonough mcdonc authored

Showing 2 changed files with 18 additions and 2 deletions. Show diff stats Hide diff stats

  1. +16 0 CHANGES.txt
  2. +2 2 setup.py
16 CHANGES.txt
... ... @@ -1,3 +1,19 @@
  1 +0.8 (unreleased)
  2 +----------------
  3 +
  4 +- Pyramid 1.3 compatibility.
  5 +
  6 +- Depend on ``zope.configuration``>=3.8.0dev in order to prevent
  7 + misconfigurations involving this package and older versions of
  8 + zope.configuration. z.config 3.8.0 uses dictionary-based actions (older
  9 + versions used tuple-based actions). Older versions of z.config will mostly
  10 + appear to work with this version of pyramid_zcml, except for cases of ZCML
  11 + which uses the includeOverrides directive; to avoid any confusion caused by
  12 + this, we upward-pin to 3.8.0dev+.
  13 +
  14 + Note that Pyramid 1.0.X, 1.1.X, 1.2.4+ and 1.3 will all still work with the
  15 + combination of pyramid_zcml 0.8 + zope.configuration 3.8.0.
  16 +
1 17 0.7 (2011-10-07)
2 18 ----------------
3 19
4 setup.py
@@ -26,7 +26,7 @@
26 26
27 27 install_requires=[
28 28 'pyramid>=1.0b1', # autktauthenticationpolicy wild_domain
29   - 'zope.configuration',
  29 + 'zope.configuration>=3.8.0dev', # dict actions
30 30 ]
31 31
32 32 if platform.system() == 'Java':
@@ -37,7 +37,7 @@
37 37 'WebTest', 'venusian']
38 38
39 39 setup(name='pyramid_zcml',
40   - version='0.7',
  40 + version='0.8dev',
41 41 description='Zope Config Markup Language support for Pyramid',
42 42 long_description=README + '\n\n' + CHANGES,
43 43 classifiers=[

0 comments on commit 8051e04

Please sign in to comment.
Something went wrong with that request. Please try again.