Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Request for Python 3.2 support #29

Closed
pboehm opened this issue Jan 12, 2014 · 4 comments
Closed

Request for Python 3.2 support #29

pboehm opened this issue Jan 12, 2014 · 4 comments

Comments

@pboehm
Copy link

@pboehm pboehm commented Jan 12, 2014

Hello,

I've come across this amazing library and found a possible bug on Python 3.2. I found this in a django extension which is tested by Travis against 2.7, 3.2 and 3.3 and on 3.2 the tests fail because of an SyntaxError in future/utils/init.py.

Traceback (most recent call last):
...
  File "/home/travis/virtualenv/python3.2/lib/python3.2/site-packages/future/utils/__init__.py", line 419
    return isinstance(obj, type(u''))
                                  ^
SyntaxError: invalid syntax

This only occurs on 3.2 as you can see here https://travis-ci.org/pboehm/django-data-migration/builds/16821855 . For me this looks like a weird error because I couldn't see and error in this line ...

@edschofield
Copy link
Contributor

@edschofield edschofield commented Jan 13, 2014

@pboehm: Thanks for mentioning this. Python 3.2 was released before PEP 414 was ratified, so future currently supports Python 3.3+ only in the 3.x series. (See here.)

The FAQ now mentions this issue as the place to request support for Python 3.2. Adding support for Python 3.2 to future would likely impose a penalty with performance and/or maintainability, so we would only do this if there were significant demand.

@pboehm
Copy link
Author

@pboehm pboehm commented Jan 13, 2014

Okay sounds reasonable. I have excluded 3.2 from testing ...

@edschofield edschofield changed the title SyntaxError in utils/__init__.py on Python 3.2 Request for Python 3.2 support May 19, 2014
@davidak
Copy link

@davidak davidak commented May 22, 2016

Python 3.2 is available on Ubuntu 12.04 LTS which is still supported until 2017, but 2.7 is installed by default.

Also PyPy3 is based on Python 3.2.5. (but it works)

@jmadler
Copy link
Collaborator

@jmadler jmadler commented Sep 10, 2018

Py3.2 is now EOL, and this request is a bit dated. Closing! :)

@jmadler jmadler closed this Sep 10, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.