Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Connect is a middleware layer for Node.js
JavaScript

This branch is 1 commit ahead, 208 commits behind senchalabs:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib
test
.gitignore
.npmignore
.travis.yml
History.md
LICENSE
Readme.md
index.js
package.json

Readme.md

Connect

NPM Version NPM Downloads Build Status Test Coverage Gittip

Connect is an extensible HTTP server framework for node using "plugins" known as middleware.

var connect = require('connect')
var http = require('http')

var app = connect()

// gzip/deflate outgoing responses
var compression = require('compression')
app.use(compression())

// store session state in browser cookie
var cookieSession = require('cookie-session')
app.use(cookieSession({
    keys: ['secret1', 'secret2']
}))

// parse urlencoded request bodies into req.body
var bodyParser = require('body-parser')
app.use(bodyParser.urlencoded())

// respond to all requests
app.use(function(req, res){
  res.end('Hello from Connect!\n');
})

//create node.js http server and listen on port
http.createServer(app).listen(3000)

Connect 3.0

Connect 3.0 is in progress in the master branch. The main changes in Connect are:

  • Middleware will be moved to their own repositories in the expressjs organization
  • All node patches will be removed - all middleware should work without Connect and with similar frameworks like restify
  • Node 0.8 is no longer supported
  • The website documentation has been removed - view the markdown readmes instead

If you would like to help maintain these middleware, please contact a member of the expressjs team.

Middleware

These middleware and libraries are officially supported by the Connect/Express team:

Most of these are exact ports of their Connect 2.x equivalents. The primary exception is cookie-session.

Some middleware previously included with Connect are no longer supported by the Connect/Express team, are replaced by an alternative module, or should be superseded by a better module. Use one of these alternatives instead:

Checkout http-framework for many other compatible middleware!

Running Tests

npm install
npm test

Contributors

https://github.com/senchalabs/connect/graphs/contributors

Node Compatibility

  • Connect < 1.x - node 0.2
  • Connect 1.x - node 0.4
  • Connect < 2.8 - node 0.6
  • Connect >= 2.8 < 3 - node 0.8
  • Connect >= 3 - node 0.10

License

MIT

Something went wrong with that request. Please try again.