No description, website, or topics provided.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.circleci
.electron-vue
.github
__tests__
build
config
src
static
.babelrc
.editorconfig
.eslintignore
.eslintrc.js
.gitignore
.nvmrc
CHANGELOG.md
LICENSE
README.md
banner.png
package.json
postcss.config.js
tailwind.js
yarn.lock

README.md

Qredit Desktop Wallet

Ark Desktop Wallet

Build Status Latest Version License: MIT

Download

Latest Release

Installing via Package Managers

Arch Linux

Install via AUR:

Manjaro

pamac build ark-desktop

Mac OS X

Install via Homebrew:

brew cask install ark-desktop-wallet

Translations

Translations are part of our ARK Development and Security Bounty Program.

Full translations are considered to be Tier 3, while grammar fixes, typos, etc. are considered to be Tier 6.

Full translations should involve 5 tasks
  • Create a pull request for the language you are going to translate. If you have doubts about something, use English to explain them.
  • Translate the textual content of the application, using the English language file as the reference. To do that, a new file, with the language locale code should be created. The name of the file should be a valid RFC 5646.
  • Add the language to the English language file at the LANGUAGES key.
  • Update the date and time formats file to include the short and long format that are used commonly by native speakers.
  • Update the number formats file to include the preferred way of displaying currencies used commonly by native speakers.
  • Add the language at the I18N.enabledLocales array at the main configuration file. This step is necessary to make the language would not be available.
  • Execute the application. Go to the development section to learn how to install the requirements and execute it.

Development

Requirements

Ubuntu

In Ubuntu the development files of libudev are necessary:

sudo apt-get install libudev-dev libusb-1.0-0-dev

Windows

  • Python 2.7
  • Visual Studio 2017

Node 9

There are certain packages (such as the ledger HID packages) which do not work on Node 10.

To download Node 9, head over to here

Yarn

Install the Yarn dependency manager

npm install -g yarn

Commands

List of commands
# Install dependencies
yarn install

# Execute the application. Making changes in the code, updates the application (hot reloading).
yarn dev

# Lint all JS/Vue files in the `src` and `__tests__`
yarn lint

# Lint, and fix, all JS/Vue files in `src` and `__tests__`
yarn lint:fix

# Check that all dependencies are used
yarn depcheck

# Collect the code and produce a compressed file
yarn pack

# Build electron application for production (Current OS)
yarn build

# Build electron application for production (Windows)
yarn build:win

# Build electron application for production (Mac)
yarn build:mac

# Build electron application for production (Linux)
yarn build:linux

# Run unit and end-to-end tests
yarn test

# Run unit tests
yarn test:unit

# Run unit tests and generate and display the coverage report
yarn test:unit:coverage

# Run unit tests and watch for changes to re-run the tests
yarn test:unit:watch

# Run end-to-end tests, without building the application
yarn test:e2e

# Build the application and run end-to-end tests
yarn test:e2e:full

Security

If you discover a security vulnerability within this project, please send an e-mail to security@ark.io. All security vulnerabilities will be promptly addressed.

Credits

License

MIT © ArkEcosystem