Permalink
Browse files

Audio support for v.redd.it, and switch to ExoPlayer #532

  • Loading branch information...
QuantumBadger committed Nov 24, 2018
1 parent 076642b commit 77a2201291f9567d9f5efc80812eaa24e1aed012
@@ -6,8 +6,8 @@ jdk: oraclejdk8
android:
components:
- tools
- android-27
- build-tools-27.0.3
- android-28
- build-tools-28.0.3
- extra-android-m2repository
script:
@@ -1,4 +1,5 @@
85/1.9.9
Audio support for v.redd.it videos using internal player
Left-handed mode preference
Preference to hide read posts (thanks to Andrew Soback)
Custom Tab preference for web browser (thanks to Cj Malone)
@@ -11,6 +12,7 @@ Indicate when posts are gilded (thanks to Sam Yuyitung)
Fixed search to match new reddit API (thanks to ianmcxa)
Visual fix for comments containing only whitespace (thanks to Briscoooe)
Crash fix for "Share Image" on Android 8.1+ (thanks to LizardWithHat)
Switched to ExoPlayer for video playback
Minor string tweaks (thanks to SkewedZeppelin)
Updated Dutch translation (thanks to Ghostkeeper)
Updated Czech translation (thanks to Mongata)
@@ -4,7 +4,7 @@ buildscript {
google()
}
dependencies {
classpath 'com.android.tools.build:gradle:3.1.4'
classpath 'com.android.tools.build:gradle:3.2.1'
}
}
@@ -20,21 +20,28 @@ dependencies {
implementation 'com.fasterxml.jackson.core:jackson-core:2.9.3'
implementation 'org.apache.commons:commons-lang3:3.7'
implementation 'joda-time:joda-time:2.9.9'
implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'com.android.support:recyclerview-v7:27.1.1'
implementation 'com.android.support:design:27.1.1'
implementation 'com.android.support:appcompat-v7:28.0.0'
implementation 'com.android.support:recyclerview-v7:28.0.0'
implementation 'com.android.support:design:28.0.0'
implementation 'com.android.support:support-media-compat:28.0.0'
implementation 'com.squareup.okhttp3:okhttp:3.10.0'
implementation 'info.guardianproject.netcipher:netcipher:1.2.1'
implementation 'com.google.android.exoplayer:exoplayer-core:2.9.1'
implementation 'com.google.android.exoplayer:exoplayer-ui:2.9.1'
testImplementation 'junit:junit:4.12'
}
android {
compileSdkVersion 27
buildToolsVersion '27.0.3'
compileSdkVersion 28
buildToolsVersion '28.0.3'
defaultConfig {
vectorDrawables.generatedDensities = ['mdpi', 'hdpi', 'xhdpi', 'xxhdpi', 'xxxhdpi']
minSdkVersion 14
targetSdkVersion 27
}
// Flag to tell aapt to keep the attribute ids around
aaptOptions {
@@ -50,9 +57,8 @@ android {
compileOptions {
compileOptions.encoding = "UTF-8"
// Use Java 1.7, requires minSdk 8
sourceCompatibility JavaVersion.VERSION_1_7
targetCompatibility JavaVersion.VERSION_1_7
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}
lintOptions {
@@ -1,7 +1,7 @@
#Thu Apr 19 21:00:53 EDT 2018
#Sat Nov 24 08:59:13 GMT 2018
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.4-all.zip
distributionSha256Sum=7a2c66d1a78f811d5f37d14630ad21cec5e77a2a4dc61e787e2257a6341016ce
distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.zip
distributionSha256Sum=9af7345c199f1731c187c96d3fe3d31f5405192a42046bafa71d846c3d9adacb
@@ -22,9 +22,6 @@
android:versionName="1.9.8.5"
android:installLocation="auto">
<uses-sdk android:minSdkVersion="14"
android:targetSdkVersion="27" />
<uses-feature android:glEsVersion="0x00020000" android:required="true" />
<uses-permission android:name="android.permission.INTERNET" />
Oops, something went wrong.

0 comments on commit 77a2201

Please sign in to comment.