Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RPM installation fails due to an error in postinst script #191

Open
krestjaninoff opened this issue Dec 10, 2015 · 1 comment
Open

RPM installation fails due to an error in postinst script #191

krestjaninoff opened this issue Dec 10, 2015 · 1 comment
Projects

Comments

@krestjaninoff
Copy link

@krestjaninoff krestjaninoff commented Dec 10, 2015

[root@master1 tmp]# yum localinstall bamboo-1.0.0_1-1.noarch.rpm 
Loaded plugins: fastestmirror
Examining bamboo-1.0.0_1-1.noarch.rpm: bamboo-1.0.0_1-1.noarch
Marking bamboo-1.0.0_1-1.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package bamboo.noarch 0:1.0.0_1-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================
 Package                    Arch                       Version                          Repository                                    Size
===========================================================================================================================================
Installing:
 bamboo                     noarch                     1.0.0_1-1                        /bamboo-1.0.0_1-1.noarch                     9.9 M

Transaction Summary
===========================================================================================================================================
Install  1 Package

Total size: 9.9 M
Installed size: 9.9 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : bamboo-1.0.0_1-1.noarch                                                                                                 1/1 
postinst called with unknown argument `1'
warning: %post(bamboo-1.0.0_1-1.noarch) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package bamboo-1.0.0_1-1.noarch
  Verifying  : bamboo-1.0.0_1-1.noarch                                                                                                 1/1 

Installed:
  bamboo.noarch 0:1.0.0_1-1                                                                                                                

Complete!

Didn't have time for investigation. Just workarounded by removing 'case' clause from builder/build.after-install script.

The package was build by instruction from README.md. The only change in 'build.sh' is about pkgtype=${_PKGTYPE:-"rpm"}

@krestjaninoff krestjaninoff changed the title RPM installation fails due to an error in postinst scripts RPM installation fails due to an error in postinst script Dec 10, 2015
@stevenlee87
Copy link

@stevenlee87 stevenlee87 commented Oct 25, 2016

same issue:
rpm -ivh bamboo-0.2.21_1-1.noarch.rpm
Preparing... ################################# [100%]
Updating / installing...
1:bamboo-0.2.21_1-1 ################################# [100%]
postinst called with unknown argument `1'
warning: %post(bamboo-0.2.21_1-1.noarch) scriptlet failed, exit status 1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Planning
Backlog
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.