New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bar is hidden under media #53

Closed
VictorLamoine opened this Issue Jun 30, 2014 · 6 comments

Comments

Projects
None yet
3 participants
@VictorLamoine
Copy link

VictorLamoine commented Jun 30, 2014

It happens that the bar appears under a media, just like on the screenshot below:
capture du 2014-06-30 23 02 47

Here is an example link: lemonde.fr (scroll down)
Disabling greasemonkey doesn't change anything.

Ubuntu 14.04 x64
Firefox 30.0
The Fox Only Better 1.1b5

@Quicksaver Quicksaver added bug labels Jul 1, 2014

@Quicksaver

This comment has been minimized.

Copy link
Owner

Quicksaver commented Jul 1, 2014

Yep this is a problem that's been showing up apparently. I have to fix this of course.

@Quicksaver

This comment has been minimized.

Copy link
Owner

Quicksaver commented Jul 20, 2014

Just a small update on this. Unfortunately I haven't found a solution for this that would work from within the add-on, not yet anyway. I did open bug 1041179 to ask the good people at mozilla what they think about this. Hopefully we'll be able to find a solution for this.

@Quicksaver

This comment has been minimized.

Copy link
Owner

Quicksaver commented Aug 24, 2014

This does seem to be a problem with the layout rendering by firefox itself. It will show the toolbars behind those embedded content objects (and others). This only happens with the Australis style (see the bug in bugzilla I linked before for more details). So as a temporary work-around, you can just choose another style.

@Quicksaver

This comment has been minimized.

Copy link
Owner

Quicksaver commented Sep 21, 2014

Kinda good news: I've just uploaded beta version 1.1.4b4 to https://addons.mozilla.org/firefox/addon/the-fox-only-better/versions/ which includes a fix for this issue. If you could please try it out and let me know if you run into any issues with it I would appreciate it.

Kinda bad news: It's not a complete fix, as there's still some visual glitches, and the animations still don't appear in these cases, but at least the toolbars should no longer be hidden behind media elements, so they should be usable in this case.

Kinda good news: in e10s (multiprocess firefox) this bug doesn't happen at all, and everything appears as it should. I was told this may change in the future, keyword being may, so there's also a chance that in a few firefox versions, when it becomes multiprocess by default, this issue should resolve itself.

@VictorLamoine

This comment has been minimized.

Copy link

VictorLamoine commented Sep 22, 2014

It works for me, the toolbar is above the media.
I notice the glitch and the lack of animation; I don't think it is a big problem.

Thanks for the fix!

@gitMat1234

This comment has been minimized.

Copy link

gitMat1234 commented Sep 28, 2014

Version 1.1.4b4 works fine also with Fire IE (i.e. using the IE engine)! Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment