Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

This fixes the issue of twi1 not working #3

Merged
merged 1 commit into from Apr 4, 2019

Conversation

Projects
None yet
2 participants
@itzandroidtab
Copy link
Contributor

itzandroidtab commented Apr 4, 2019

Bugfix for the TWI1 interface. This removes some |= on registers that can not be read from as well.

removed all the |= from registers you cant read from and added some c…
…omments, and added a way to change the pin from a different pio addr since twi1 uses piob instead of pioa

@itzandroidtab itzandroidtab added the bug label Apr 4, 2019

@itzandroidtab itzandroidtab requested a review from florianhumblot Apr 4, 2019

@florianhumblot
Copy link
Contributor

florianhumblot left a comment

Code changes look good, I've also tested the hotfix using the display module and both interfaces work now.

@florianhumblot florianhumblot merged commit 30d209f into release Apr 4, 2019

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@itzandroidtab itzandroidtab deleted the hotfix-twi1_not_working branch Apr 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.