Skip to content
Browse files

Version bump to 1.3.0

  • Loading branch information...
1 parent f9d6b0d commit 4944ef3f44681d94d2e2e890bf3921e6b55bab91 @RISCfuture committed Jul 19, 2011
Showing with 21 additions and 21 deletions.
  1. +11 −0 ChangeLog
  2. +1 −1 VERSION
  3. +9 −20 dropbox.gemspec
View
11 ChangeLog
@@ -1,3 +1,14 @@
+1.3.0 (2011-07-19)
+
+* NOTE: Removed the ability to automate the OAuth form.
+* Added a method allowing users to manually set the access token and secret (in
+ case you are doing your own OAuth elsewhere).
+* The mode (Dropbox or Sandbox) is now serialized.
+* Fixed a bug that would cause files uploaded into deep paths to fail due to
+ name length limitations.
+* Fixed a bug that would cause abnormal OAuth requests when deserializing an
+ authorized session.
+
1.2.3 (2011-01-14)
* Now supports caching metadata calls
View
2 VERSION
@@ -1 +1 @@
-1.2.3
+1.3.0
View
29 dropbox.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{dropbox}
- s.version = "1.2.3"
+ s.version = "1.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Tim Morgan"]
- s.date = %q{2011-01-14}
+ s.date = %q{2011-07-19}
s.description = %q{An easy-to-use client library for the official Dropbox API.}
s.email = %q{dropbox@timothymorgan.info}
s.extra_rdoc_files = [
@@ -53,45 +53,34 @@ Gem::Specification.new do |s|
]
s.homepage = %q{http://github.com/RISCfuture/dropbox}
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
+ s.rubygems_version = %q{1.6.2}
s.summary = %q{Ruby client library for the official Dropbox API}
- s.test_files = [
- "examples/upload_and_delete.rb",
- "spec/dropbox/api_spec.rb",
- "spec/dropbox/entry_spec.rb",
- "spec/dropbox/event_spec.rb",
- "spec/dropbox/revision_spec.rb",
- "spec/dropbox/session_spec.rb",
- "spec/dropbox_spec.rb",
- "spec/spec_helper.rb"
- ]
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<oauth>, [">= 0.3.6"])
s.add_runtime_dependency(%q<json>, [">= 1.2.0"])
- s.add_runtime_dependency(%q<multipart-post>, [">= 1.0"])
- s.add_runtime_dependency(%q<mechanize>, [">= 1.0.0"])
+ s.add_runtime_dependency(%q<multipart-post>, [">= 1.1.0"])
s.add_development_dependency(%q<jeweler>, [">= 0"])
s.add_development_dependency(%q<rspec>, [">= 2.0"])
+ s.add_development_dependency(%q<mechanize>, [">= 0"])
else
s.add_dependency(%q<oauth>, [">= 0.3.6"])
s.add_dependency(%q<json>, [">= 1.2.0"])
- s.add_dependency(%q<multipart-post>, [">= 1.0"])
- s.add_dependency(%q<mechanize>, [">= 1.0.0"])
+ s.add_dependency(%q<multipart-post>, [">= 1.1.0"])
s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 2.0"])
+ s.add_dependency(%q<mechanize>, [">= 0"])
end
else
s.add_dependency(%q<oauth>, [">= 0.3.6"])
s.add_dependency(%q<json>, [">= 1.2.0"])
- s.add_dependency(%q<multipart-post>, [">= 1.0"])
- s.add_dependency(%q<mechanize>, [">= 1.0.0"])
+ s.add_dependency(%q<multipart-post>, [">= 1.1.0"])
s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 2.0"])
+ s.add_dependency(%q<mechanize>, [">= 0"])
end
end

0 comments on commit 4944ef3

Please sign in to comment.
Something went wrong with that request. Please try again.