Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Unable to compile php-extension in Ubuntu 12.10 #7

Open
sfernandez opened this Issue Jul 25, 2013 · 1 comment

Comments

Projects
None yet
1 participant

Once properly compiled and installed libketama (installed in /usr/lib), I'm unable to compile the php extension.

steps:

  • phpize
  • configure
    and the following error will appear:
    checking for ketama_roll in -lketama... no

Ok the solution is the following;

  • change the following line of libketama Makefile build target:
    gcc -shared -Wl,-soname,libketama.so.1 -o libketama.so.1 -lm ketama.o md5.o ---> gcc -shared
    -Wl,-soname,libketama.so.1 -o libketama.so.1 ketama.o md5.o -lm

in php_ketama execute ./configure --with-ketama instead of ./configure

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment