Skip to content
Browse files

conform to app generated by template for Rails 3.1.0 final

  • Loading branch information...
1 parent 143257f commit 4160e732f886e0360caaeefac6ab47d5a4b2716e @DanielKehoe DanielKehoe committed Sep 1, 2011
Showing with 137 additions and 98 deletions.
  1. +6 −5 Gemfile
  2. +112 −92 Gemfile.lock
  3. +4 −1 config/application.rb
  4. +3 −0 config/environments/development.rb
  5. +9 −0 config/environments/production.rb
  6. +3 −0 config/environments/test.rb
View
11 Gemfile
@@ -1,8 +1,8 @@
source 'http://rubygems.org'
-gem 'rails', '3.1.0.rc6'
+gem 'rails', '3.1.0'
group :assets do
- gem 'sass-rails', " ~> 3.1.0.rc"
- gem 'coffee-rails', "~> 3.1.0.rc"
+ gem 'sass-rails', " ~> 3.1.0"
+ gem 'coffee-rails', "~> 3.1.0"
gem 'uglifier'
end
gem 'jquery-rails'
@@ -12,6 +12,7 @@ gem "mongoid-rspec", ">= 1.4.4", :group => :test
gem "factory_girl_rails", ">= 1.1.0", :group => :test
gem "cucumber-rails", ">= 1.0.2", :group => :test
gem "capybara", ">= 1.0.1", :group => :test
+gem "launchy", ">= 2.0.5", :group => :test
gem "bson_ext", ">= 1.3.1"
-gem "mongoid", ">= 2.1.9"
-gem "omniauth", ">= 0.2.6"
+gem "mongoid", ">= 2.2.0"
+gem "omniauth", ">= 0.2.6", :git => "git://github.com/intridea/omniauth.git"
View
204 Gemfile.lock
@@ -1,38 +1,80 @@
+GIT
+ remote: git://github.com/intridea/omniauth.git
+ revision: 2a3e8ba45683fd87d4b88b7478e60f20d5ffa95e
+ specs:
+ oa-basic (0.3.0.rc1)
+ oa-core (= 0.3.0.rc1)
+ rest-client (~> 1.6.0)
+ oa-core (0.3.0.rc1)
+ oa-enterprise (0.3.0.rc1)
+ XMLCanonicalizer (~> 1.0.1)
+ addressable (~> 2.2.6)
+ net-ldap (~> 0.2.2)
+ nokogiri (~> 1.5.0)
+ oa-core (= 0.3.0.rc1)
+ pyu-ruby-sasl (~> 0.0.3.1)
+ rubyntlm (~> 0.1.1)
+ uuid
+ oa-more (0.3.0.rc1)
+ multi_json (~> 1.0.0)
+ oa-core (= 0.3.0.rc1)
+ rest-client (~> 1.6.0)
+ oa-oauth (0.3.0.rc1)
+ faraday (~> 0.7.3)
+ multi_json (~> 1.0.0)
+ multi_xml (~> 0.3.0)
+ oa-core (= 0.3.0.rc1)
+ oauth (~> 0.4.0)
+ oauth2 (~> 0.5.0)
+ oa-openid (0.3.0.rc1)
+ oa-core (= 0.3.0.rc1)
+ rack-openid (~> 1.3.1)
+ ruby-openid-apps-discovery (~> 1.2.0)
+ omniauth (0.3.0.rc1)
+ oa-basic (= 0.3.0.rc1)
+ oa-core (= 0.3.0.rc1)
+ oa-enterprise (= 0.3.0.rc1)
+ oa-more (= 0.3.0.rc1)
+ oa-oauth (= 0.3.0.rc1)
+ oa-openid (= 0.3.0.rc1)
+
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.0.rc6)
- actionpack (= 3.1.0.rc6)
+ XMLCanonicalizer (1.0.1)
+ log4r (>= 1.0.4)
+ actionmailer (3.1.0)
+ actionpack (= 3.1.0)
mail (~> 2.3.0)
- actionpack (3.1.0.rc6)
- activemodel (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ actionpack (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
builder (~> 3.0.0)
erubis (~> 2.7.0)
i18n (~> 0.6)
rack (~> 1.3.2)
- rack-cache (~> 1.0.2)
- rack-mount (~> 0.8.1)
- rack-test (~> 0.6.0)
- sprockets (~> 2.0.0.beta.12)
- activemodel (3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
- bcrypt-ruby (~> 2.1.4)
+ rack-cache (~> 1.0.3)
+ rack-mount (~> 0.8.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.0.0)
+ activemodel (3.1.0)
+ activesupport (= 3.1.0)
+ bcrypt-ruby (~> 3.0.0)
builder (~> 3.0.0)
i18n (~> 0.6)
- activerecord (3.1.0.rc6)
- activemodel (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ activerecord (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
arel (~> 2.2.1)
tzinfo (~> 0.3.29)
- activeresource (3.1.0.rc6)
- activemodel (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
- activesupport (3.1.0.rc6)
+ activeresource (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ activesupport (3.1.0)
multi_json (~> 1.0)
- addressable (2.2.4)
+ addressable (2.2.6)
arel (2.2.1)
- bcrypt-ruby (2.1.4)
+ bcrypt-ruby (3.0.0)
bson (1.3.1)
bson_ext (1.3.1)
builder (3.0.0)
@@ -43,9 +85,9 @@ GEM
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.2.1)
+ childprocess (0.2.2)
ffi (~> 1.0.6)
- coffee-rails (3.1.0.rc.6)
+ coffee-rails (3.1.0)
coffee-script (>= 2.2.0)
railties (~> 3.1.0.rc1)
coffee-script (2.2.0)
@@ -63,90 +105,63 @@ GEM
cucumber (~> 1.0.0)
nokogiri (>= 1.4.6)
database_cleaner (0.6.7)
- diff-lcs (1.1.2)
+ diff-lcs (1.1.3)
erubis (2.7.0)
execjs (1.2.4)
multi_json (~> 1.0)
factory_girl (2.0.5)
factory_girl_rails (1.1.0)
factory_girl (~> 2.0.0)
railties (>= 3.0.0)
- faraday (0.6.1)
- addressable (~> 2.2.4)
+ faraday (0.7.4)
+ addressable (~> 2.2.6)
multipart-post (~> 1.1.0)
rack (< 2, >= 1.1.0)
ffi (1.0.9)
- gherkin (2.4.15)
+ gherkin (2.4.16)
json (>= 1.4.6)
hike (1.2.1)
i18n (0.6.0)
jquery-rails (1.0.13)
railties (~> 3.0)
thor (~> 0.14)
- json (1.5.3)
- json_pure (1.5.3)
+ json (1.5.4)
+ json_pure (1.5.4)
+ spruz (~> 0.2.8)
+ launchy (2.0.5)
+ addressable (~> 2.2.6)
+ log4r (1.1.9)
+ macaddr (1.4.0)
+ systemu (~> 2.2.0)
mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.16)
mongo (1.3.1)
bson (>= 1.3.1)
- mongoid (2.1.9)
+ mongoid (2.2.0)
activemodel (~> 3.0)
mongo (~> 1.3)
tzinfo (~> 0.3.22)
mongoid-rspec (1.4.4)
mongoid (~> 2.0)
rspec (~> 2)
multi_json (1.0.3)
- multi_xml (0.2.2)
+ multi_xml (0.3.0)
multipart-post (1.1.3)
net-ldap (0.2.2)
- nokogiri (1.4.7)
- oa-basic (0.2.6)
- oa-core (= 0.2.6)
- rest-client (~> 1.6.0)
- oa-core (0.2.6)
- oa-enterprise (0.2.6)
- addressable (= 2.2.4)
- net-ldap (~> 0.2.2)
- nokogiri (~> 1.4.2)
- oa-core (= 0.2.6)
- pyu-ruby-sasl (~> 0.0.3.1)
- rubyntlm (~> 0.1.1)
- oa-more (0.2.6)
- multi_json (~> 1.0.0)
- oa-core (= 0.2.6)
- rest-client (~> 1.6.0)
- oa-oauth (0.2.6)
- faraday (~> 0.6.1)
- multi_json (~> 1.0.0)
- multi_xml (~> 0.2.2)
- oa-core (= 0.2.6)
- oauth (~> 0.4.0)
- oauth2 (~> 0.4.1)
- oa-openid (0.2.6)
- oa-core (= 0.2.6)
- rack-openid (~> 1.3.1)
- ruby-openid-apps-discovery (~> 1.2.0)
+ nokogiri (1.5.0)
oauth (0.4.5)
- oauth2 (0.4.1)
- faraday (~> 0.6.1)
- multi_json (>= 0.0.5)
- omniauth (0.2.6)
- oa-basic (= 0.2.6)
- oa-core (= 0.2.6)
- oa-enterprise (= 0.2.6)
- oa-more (= 0.2.6)
- oa-oauth (= 0.2.6)
- oa-openid (= 0.2.6)
+ oauth2 (0.5.0)
+ faraday (< 0.8, >= 0.6.1)
+ multi_json (~> 1.0.0)
polyglot (0.3.2)
pyu-ruby-sasl (0.0.3.3)
rack (1.3.2)
- rack-cache (1.0.2)
+ rack-cache (1.0.3)
rack (>= 0.4)
- rack-mount (0.8.2)
+ rack-mount (0.8.3)
rack (>= 1.0.0)
rack-openid (1.3.1)
rack (>= 1.1.0)
@@ -155,23 +170,23 @@ GEM
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.0.rc6)
- actionmailer (= 3.1.0.rc6)
- actionpack (= 3.1.0.rc6)
- activerecord (= 3.1.0.rc6)
- activeresource (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ rails (3.1.0)
+ actionmailer (= 3.1.0)
+ actionpack (= 3.1.0)
+ activerecord (= 3.1.0)
+ activeresource (= 3.1.0)
+ activesupport (= 3.1.0)
bundler (~> 1.0)
- railties (= 3.1.0.rc6)
- railties (3.1.0.rc6)
- actionpack (= 3.1.0.rc6)
- activesupport (= 3.1.0.rc6)
+ railties (= 3.1.0)
+ railties (3.1.0)
+ actionpack (= 3.1.0)
+ activesupport (= 3.1.0)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2)
- rdoc (3.9.3)
+ rdoc (3.9.4)
rest-client (1.6.7)
mime-types (>= 1.16)
rspec (2.6.0)
@@ -193,29 +208,33 @@ GEM
rubyntlm (0.1.1)
rubyzip (0.9.4)
sass (3.1.7)
- sass-rails (3.1.0.rc.6)
- actionpack (~> 3.1.0.rc6)
- railties (~> 3.1.0.rc6)
+ sass-rails (3.1.0)
+ actionpack (~> 3.1.0)
+ railties (~> 3.1.0)
sass (>= 3.1.4)
selenium-webdriver (2.5.0)
childprocess (>= 0.2.1)
ffi (>= 1.0.7)
json_pure
rubyzip
- sprockets (2.0.0.beta.14)
+ sprockets (2.0.0)
hike (~> 1.2)
rack (~> 1.0)
tilt (!= 1.3.0, ~> 1.1)
+ spruz (0.2.13)
+ systemu (2.2.0)
term-ansicolor (1.0.6)
thor (0.14.6)
- tilt (1.3.2)
+ tilt (1.3.3)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
tzinfo (0.3.29)
- uglifier (1.0.1)
+ uglifier (1.0.2)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
+ uuid (2.3.3)
+ macaddr (~> 1.0)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -225,15 +244,16 @@ PLATFORMS
DEPENDENCIES
bson_ext (>= 1.3.1)
capybara (>= 1.0.1)
- coffee-rails (~> 3.1.0.rc)
+ coffee-rails (~> 3.1.0)
cucumber-rails (>= 1.0.2)
database_cleaner (>= 0.6.7)
factory_girl_rails (>= 1.1.0)
jquery-rails
- mongoid (>= 2.1.9)
+ launchy (>= 2.0.5)
+ mongoid (>= 2.2.0)
mongoid-rspec (>= 1.4.4)
- omniauth (>= 0.2.6)
- rails (= 3.1.0.rc6)
+ omniauth (>= 0.2.6)!
+ rails (= 3.1.0)
rspec-rails (>= 2.6.1)
- sass-rails (~> 3.1.0.rc)
+ sass-rails (~> 3.1.0)
uglifier
View
5 config/application.rb
@@ -5,7 +5,7 @@
require "action_controller/railtie"
require "action_mailer/railtie"
require "active_resource/railtie"
- require "sprockets/railtie"
+require "sprockets/railtie"
# # require "rails/test_unit/railtie"
if defined?(Bundler)
@@ -54,5 +54,8 @@ class Application < Rails::Application
# Enable the asset pipeline
config.assets.enabled = true
+
+ # Version of your assets, change this if you want to expire all your assets
+ config.assets.version = '1.0'
end
end
View
3 config/environments/development.rb
@@ -24,4 +24,7 @@
# Do not compress assets
config.assets.compress = false
+
+ # Expands the lines which load the assets
+ config.assets.debug = true
end
View
9 config/environments/production.rb
@@ -14,6 +14,15 @@
# Compress JavaScripts and CSS
config.assets.compress = true
+ # Don't fallback to assets pipeline if a precompiled asset is missed
+ config.assets.compile = false
+
+ # Generate digests for assets URLs
+ config.assets.digest = true
+
+ # Defaults to Rails.root.join("public/assets")
+ # config.assets.manifest = YOUR_PATH
+
# Specifies the header that your server uses for sending files
# config.action_dispatch.x_sendfile_header = "X-Sendfile" # for apache
# config.action_dispatch.x_sendfile_header = 'X-Accel-Redirect' # for nginx
View
3 config/environments/test.rb
@@ -36,4 +36,7 @@
# Print deprecation notices to the stderr
config.active_support.deprecation = :stderr
+
+ # Allow pass debug_assets=true as a query parameter to load pages with unpackaged assets
+ config.assets.allow_debugging = true
end

0 comments on commit 4160e73

Please sign in to comment.
Something went wrong with that request. Please try again.