This repository has been archived by the owner. It is now read-only.

How to use with Maven

Raimund Hocke edited this page Nov 7, 2017 · 5 revisions

How to define the dependency to sikulixapi.jar.

This is related to SikuliX 1.1.1+ (not version 2!). SikuliX 1.1.0 is no longer supported - use 1.1.1

This is the dependency for sikulixapi

For the current release version 1.1.1:

<dependency>
  <groupId>com.sikulix</groupId>
  <artifactId>sikulixapi</artifactId>
  <version>1.1.1</version>
</dependency>

If you want to use the latest SNAPSHOT version (related to a nightly build), you need a repository entry:

<repository>
  <id>sonatype-ossrh</id>
  <url>https://oss.sonatype.org/content/repositories/snapshots/</url>
</repository>

... and in the above dependency for sikulixapi use:

  <version>1.1.2-SNAPSHOT</version>

Be aware: snapshot versions before 1.1.2 are no longer supported.

You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.