Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

build using rails_apps_composer 2.2.34

  • Loading branch information...
commit 11b984b02ef74332c0e15cfb732ddac8a4d89f16 1 parent 8d2ab69
@DanielKehoe DanielKehoe authored
View
22 .rvmrc
@@ -9,7 +9,7 @@
environment_id="ruby-1.9.3@rails3-devise-rspec-cucumber"
# Uncomment the following lines if you want to verify rvm version per project
-# rvmrc_rvm_version="1.14.2 (latest)" # 1.10.1 seams as a safe start
+# rvmrc_rvm_version="1.18.6 (latest)" # 1.10.1 seams as a safe start
# eval "$(echo ${rvm_version}.${rvmrc_rvm_version} | awk -F. '{print "[[ "$1*65536+$2*256+$3" -ge "$4*65536+$5*256+$6" ]]"}' )" || {
# echo "This .rvmrc file requires at least RVM ${rvmrc_rvm_version}, aborting loading."
# return 1
@@ -25,24 +25,14 @@ then
\. "${rvm_path:-$HOME/.rvm}/environments/$environment_id"
[[ -s "${rvm_path:-$HOME/.rvm}/hooks/after_use" ]] &&
\. "${rvm_path:-$HOME/.rvm}/hooks/after_use" || true
+ if [[ $- == *i* ]] # check for interactive shells
+ then echo "Using: $(tput setaf 2)$GEM_HOME$(tput sgr0)" # show the user the ruby and gemset they are using in green
+ else echo "Using: $GEM_HOME" # don't use colors in non-interactive shells
+ fi
else
# If the environment file has not yet been created, use the RVM CLI to select.
- rvm --create "$environment_id" || {
+ rvm --create use "$environment_id" || {
echo "Failed to create RVM environment '${environment_id}'."
return 1
}
fi
-
-# If you use bundler, this might be useful to you:
-# if [[ -s Gemfile ]] && {
-# ! builtin command -v bundle >/dev/null ||
-# builtin command -v bundle | GREP_OPTIONS= \grep $rvm_path/bin/bundle >/dev/null
-# }
-# then
-# printf "%b" "The rubygem 'bundler' is not installed. Installing it now.\n"
-# gem install bundler
-# fi
-# if [[ -s Gemfile ]] && builtin command -v bundle >/dev/null
-# then
-# bundle install | GREP_OPTIONS= \grep -vE '^Using|Your bundle is complete'
-# fi
View
8 Gemfile
@@ -1,5 +1,5 @@
source 'https://rubygems.org'
-gem 'rails', '3.2.11'
+gem 'rails', '3.2.12'
gem 'sqlite3'
group :assets do
gem 'sass-rails', '~> 3.2.3'
@@ -11,11 +11,11 @@ gem "rspec-rails", ">= 2.12.2", :group => [:development, :test]
gem "database_cleaner", ">= 0.9.1", :group => :test
gem "email_spec", ">= 1.4.0", :group => :test
gem "cucumber-rails", ">= 1.3.0", :group => :test, :require => false
-gem "launchy", ">= 2.1.2", :group => :test
+gem "launchy", ">= 2.2.0", :group => :test
gem "capybara", ">= 2.0.2", :group => :test
gem "factory_girl_rails", ">= 4.2.0", :group => [:development, :test]
gem "devise", ">= 2.2.3"
gem "quiet_assets", ">= 1.0.1", :group => :development
gem "figaro", ">= 0.5.3"
-gem "better_errors", ">= 0.3.2", :group => :development
-gem "binding_of_caller", ">= 0.6.8", :group => :development
+gem "better_errors", ">= 0.6.0", :group => :development
+gem "binding_of_caller", ">= 0.7.1", :group => :development, :platforms => [:mri_19, :rbx]
View
94 Gemfile.lock
@@ -1,40 +1,41 @@
GEM
remote: https://rubygems.org/
specs:
- actionmailer (3.2.11)
- actionpack (= 3.2.11)
+ actionmailer (3.2.12)
+ actionpack (= 3.2.12)
mail (~> 2.4.4)
- actionpack (3.2.11)
- activemodel (= 3.2.11)
- activesupport (= 3.2.11)
+ actionpack (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
- rack (~> 1.4.0)
+ rack (~> 1.4.5)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
sprockets (~> 2.2.1)
- activemodel (3.2.11)
- activesupport (= 3.2.11)
+ activemodel (3.2.12)
+ activesupport (= 3.2.12)
builder (~> 3.0.0)
- activerecord (3.2.11)
- activemodel (= 3.2.11)
- activesupport (= 3.2.11)
+ activerecord (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.11)
- activemodel (= 3.2.11)
- activesupport (= 3.2.11)
- activesupport (3.2.11)
+ activeresource (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ activesupport (3.2.12)
i18n (~> 0.6)
multi_json (~> 1.0)
- addressable (2.3.2)
+ addressable (2.3.3)
arel (3.0.2)
bcrypt-ruby (3.0.1)
- better_errors (0.3.2)
+ better_errors (0.6.0)
coderay (>= 1.0.0)
- erubis (>= 2.7.0)
- binding_of_caller (0.6.8)
+ erubis (>= 2.6.6)
+ binding_of_caller (0.7.1)
+ debug_inspector (>= 0.0.1)
builder (3.0.4)
capybara (2.0.2)
mime-types (>= 1.16)
@@ -43,9 +44,9 @@ GEM
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 1.0.0)
- childprocess (0.3.7)
- ffi (~> 1.0, >= 1.0.6)
- coderay (1.0.8)
+ childprocess (0.3.8)
+ ffi (~> 1.0, >= 1.0.11)
+ coderay (1.0.9)
coffee-rails (3.2.2)
coffee-script (>= 2.2.0)
railties (~> 3.2.0)
@@ -63,6 +64,7 @@ GEM
cucumber (>= 1.1.8)
nokogiri (>= 1.5.0)
database_cleaner (0.9.1)
+ debug_inspector (0.0.2)
devise (2.2.3)
bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.1)
@@ -77,10 +79,10 @@ GEM
multi_json (~> 1.0)
factory_girl (4.2.0)
activesupport (>= 3.0.0)
- factory_girl_rails (4.2.0)
+ factory_girl_rails (4.2.1)
factory_girl (~> 4.2.0)
railties (>= 3.0.0)
- ffi (1.3.1)
+ ffi (1.4.0)
figaro (0.5.3)
rails (~> 3.0)
gherkin (2.11.6)
@@ -88,47 +90,47 @@ GEM
hike (1.2.1)
i18n (0.6.1)
journey (1.0.4)
- jquery-rails (2.2.0)
+ jquery-rails (2.2.1)
railties (>= 3.0, < 5.0)
thor (>= 0.14, < 2.0)
- json (1.7.6)
- launchy (2.1.2)
+ json (1.7.7)
+ launchy (2.2.0)
addressable (~> 2.3)
mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.19)
- multi_json (1.5.0)
+ mime-types (1.21)
+ multi_json (1.6.1)
nokogiri (1.5.6)
orm_adapter (0.4.0)
polyglot (0.3.3)
quiet_assets (1.0.1)
railties (~> 3.1)
- rack (1.4.4)
+ rack (1.4.5)
rack-cache (1.2)
rack (>= 0.4)
rack-ssl (1.3.3)
rack
rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.11)
- actionmailer (= 3.2.11)
- actionpack (= 3.2.11)
- activerecord (= 3.2.11)
- activeresource (= 3.2.11)
- activesupport (= 3.2.11)
+ rails (3.2.12)
+ actionmailer (= 3.2.12)
+ actionpack (= 3.2.12)
+ activerecord (= 3.2.12)
+ activeresource (= 3.2.12)
+ activesupport (= 3.2.12)
bundler (~> 1.0)
- railties (= 3.2.11)
- railties (3.2.11)
- actionpack (= 3.2.11)
- activesupport (= 3.2.11)
+ railties (= 3.2.12)
+ railties (3.2.12)
+ actionpack (= 3.2.12)
+ activesupport (= 3.2.12)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
rake (10.0.3)
- rdoc (3.12)
+ rdoc (3.12.1)
json (~> 1.4)
rspec-core (2.12.2)
rspec-expectations (2.12.1)
@@ -147,7 +149,7 @@ GEM
railties (~> 3.2.0)
sass (>= 3.1.10)
tilt (~> 1.3)
- selenium-webdriver (2.29.0)
+ selenium-webdriver (2.30.0)
childprocess (>= 0.2.5)
multi_json (~> 1.0)
rubyzip
@@ -177,8 +179,8 @@ PLATFORMS
ruby
DEPENDENCIES
- better_errors (>= 0.3.2)
- binding_of_caller (>= 0.6.8)
+ better_errors (>= 0.6.0)
+ binding_of_caller (>= 0.7.1)
capybara (>= 2.0.2)
coffee-rails (~> 3.2.1)
cucumber-rails (>= 1.3.0)
@@ -188,9 +190,9 @@ DEPENDENCIES
factory_girl_rails (>= 4.2.0)
figaro (>= 0.5.3)
jquery-rails
- launchy (>= 2.1.2)
+ launchy (>= 2.2.0)
quiet_assets (>= 1.0.1)
- rails (= 3.2.11)
+ rails (= 3.2.12)
rspec-rails (>= 2.12.2)
sass-rails (~> 3.2.3)
sqlite3
View
8 config/application.rb
@@ -1,12 +1,6 @@
require File.expand_path('../boot', __FILE__)
-# Pick the frameworks you want:
-require "active_record/railtie"
-require "action_controller/railtie"
-require "action_mailer/railtie"
-require "active_resource/railtie"
-require "sprockets/railtie"
-# require "rails/test_unit/railtie"
+require 'rails/all'
if defined?(Bundler)
# If you precompile assets before deploying to production, use this line
View
2  config/environments/test.rb
@@ -34,7 +34,7 @@
# Print deprecation notices to the stderr
config.active_support.deprecation = :stderr
-
+
# ActionMailer Config
config.action_mailer.default_url_options = { :host => 'example.com' }
Please sign in to comment.
Something went wrong with that request. Please try again.