Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

build using rails_apps_composer 2.2.20

  • Loading branch information...
commit ad145f743d54dc7290078055f00cebcbbb78f82a 1 parent f4084b9
@DanielKehoe DanielKehoe authored
View
8 .gitignore
@@ -4,15 +4,16 @@
# See http://help.github.com/ignore-files/ for more about ignoring files.
#
# The original version of this file is found here:
-# https://github.com/RailsApps/rails3-application-templates/raw/master/files/gitignore.txt
+# https://github.com/RailsApps/rails-composer/blob/master/files/gitignore.txt
#
# Corrections? Improvements? Create a GitHub issue:
-# http://github.com/RailsApps/rails3-application-templates/issues
+# http://github.com/RailsApps/rails-composer/issues
#----------------------------------------------------------------------------
# bundler state
/.bundle
/vendor/bundle/
+/vendor/ruby/
# minimal Rails specific artifacts
db/*.sqlite3
@@ -44,9 +45,6 @@ db/*.sqlite3
/capybara*
/capybara-*.html
/gems
-/spec/requests
-/spec/routing
-/spec/views
/specifications
rerun.txt
pickle-email-*.html
View
14 Gemfile
@@ -1,19 +1,19 @@
source 'https://rubygems.org'
-gem 'rails', '3.2.8'
+gem 'rails', '3.2.9'
group :assets do
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
gem 'uglifier', '>= 1.0.3'
end
gem 'jquery-rails'
-gem "mongoid", ">= 3.0.6"
-gem "rspec-rails", ">= 2.11.0", :group => [:development, :test]
-gem "database_cleaner", ">= 0.8.0", :group => :test
-gem "mongoid-rspec", ">= 1.4.6", :group => :test
-gem "email_spec", ">= 1.2.1", :group => :test
+gem "mongoid", ">= 3.0.14"
+gem "rspec-rails", ">= 2.11.4", :group => [:development, :test]
+gem "database_cleaner", ">= 0.9.1", :group => :test
+gem "mongoid-rspec", ">= 1.5.5", :group => :test
+gem "email_spec", ">= 1.4.0", :group => :test
gem "cucumber-rails", ">= 1.3.0", :group => :test, :require => false
gem "launchy", ">= 2.1.2", :group => :test
-gem "capybara", ">= 1.1.2", :group => :test
+gem "capybara", ">= 1.1.4", :group => :test
gem "factory_girl_rails", ">= 4.1.0", :group => [:development, :test]
gem "devise", ">= 2.1.2"
gem "quiet_assets", ">= 1.0.1", :group => :development
View
137 Gemfile.lock
@@ -1,45 +1,45 @@
GEM
remote: https://rubygems.org/
specs:
- actionmailer (3.2.8)
- actionpack (= 3.2.8)
+ actionmailer (3.2.9)
+ actionpack (= 3.2.9)
mail (~> 2.4.4)
- actionpack (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
+ actionpack (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
rack (~> 1.4.0)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.1.3)
- activemodel (3.2.8)
- activesupport (= 3.2.8)
+ sprockets (~> 2.2.1)
+ activemodel (3.2.9)
+ activesupport (= 3.2.9)
builder (~> 3.0.0)
- activerecord (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
+ activerecord (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
- activesupport (3.2.8)
+ activeresource (3.2.9)
+ activemodel (= 3.2.9)
+ activesupport (= 3.2.9)
+ activesupport (3.2.9)
i18n (~> 0.6)
multi_json (~> 1.0)
addressable (2.3.2)
arel (3.0.2)
bcrypt-ruby (3.0.1)
- builder (3.0.3)
- capybara (1.1.2)
+ builder (3.0.4)
+ capybara (2.0.1)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
- xpath (~> 0.1.4)
- childprocess (0.3.5)
+ xpath (~> 1.0.0)
+ childprocess (0.3.6)
ffi (~> 1.0, >= 1.0.6)
coffee-rails (3.2.2)
coffee-script (>= 2.2.0)
@@ -47,7 +47,7 @@ GEM
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.3.3)
+ coffee-script-source (1.4.0)
cucumber (1.2.1)
builder (>= 2.1.2)
diff-lcs (>= 1.1.3)
@@ -64,9 +64,9 @@ GEM
railties (~> 3.1)
warden (~> 1.2.1)
diff-lcs (1.1.3)
- email_spec (1.2.1)
+ email_spec (1.4.0)
+ launchy (~> 2.1)
mail (~> 2.2)
- rspec (~> 2.0)
erubis (2.7.0)
execjs (1.4.0)
multi_json (~> 1.0)
@@ -75,38 +75,39 @@ GEM
factory_girl_rails (4.1.0)
factory_girl (~> 4.1.0)
railties (>= 3.0.0)
- ffi (1.1.5)
- gherkin (2.11.4)
+ ffi (1.2.0)
+ gherkin (2.11.5)
json (>= 1.4.6)
hike (1.2.1)
i18n (0.6.1)
journey (1.0.4)
- jquery-rails (2.1.3)
- railties (>= 3.1.0, < 5.0)
- thor (~> 0.14)
+ jquery-rails (2.1.4)
+ railties (>= 3.0, < 5.0)
+ thor (>= 0.14, < 2.0)
json (1.7.5)
launchy (2.1.2)
addressable (~> 2.3)
- libwebsocket (0.1.5)
+ libwebsocket (0.1.7.1)
addressable
+ websocket
mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.19)
- mongoid (3.0.9)
+ mongoid (3.0.14)
activemodel (~> 3.1)
moped (~> 1.1)
origin (~> 1.0)
tzinfo (~> 0.3.22)
- mongoid-rspec (1.5.4)
+ mongoid-rspec (1.5.5)
mongoid (>= 3.0.1)
rake
rspec (>= 2.9)
- moped (1.2.7)
- multi_json (1.3.6)
+ moped (1.3.1)
+ multi_json (1.4.0)
nokogiri (1.5.5)
- origin (1.0.9)
+ origin (1.0.11)
orm_adapter (0.4.0)
polyglot (0.3.3)
quiet_assets (1.0.1)
@@ -118,83 +119,87 @@ GEM
rack
rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.8)
- actionmailer (= 3.2.8)
- actionpack (= 3.2.8)
- activerecord (= 3.2.8)
- activeresource (= 3.2.8)
- activesupport (= 3.2.8)
+ rails (3.2.9)
+ actionmailer (= 3.2.9)
+ actionpack (= 3.2.9)
+ activerecord (= 3.2.9)
+ activeresource (= 3.2.9)
+ activesupport (= 3.2.9)
bundler (~> 1.0)
- railties (= 3.2.8)
- railties (3.2.8)
- actionpack (= 3.2.8)
- activesupport (= 3.2.8)
+ railties (= 3.2.9)
+ railties (3.2.9)
+ actionpack (= 3.2.9)
+ activesupport (= 3.2.9)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
- rake (0.9.2.2)
+ rake (10.0.2)
rdoc (3.12)
json (~> 1.4)
- rspec (2.11.0)
- rspec-core (~> 2.11.0)
- rspec-expectations (~> 2.11.0)
- rspec-mocks (~> 2.11.0)
- rspec-core (2.11.1)
- rspec-expectations (2.11.3)
+ rspec (2.12.0)
+ rspec-core (~> 2.12.0)
+ rspec-expectations (~> 2.12.0)
+ rspec-mocks (~> 2.12.0)
+ rspec-core (2.12.1)
+ rspec-expectations (2.12.0)
diff-lcs (~> 1.1.3)
- rspec-mocks (2.11.3)
- rspec-rails (2.11.0)
+ rspec-mocks (2.12.0)
+ rspec-rails (2.12.0)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
- rspec (~> 2.11.0)
+ rspec-core (~> 2.12.0)
+ rspec-expectations (~> 2.12.0)
+ rspec-mocks (~> 2.12.0)
rubyzip (0.9.9)
- sass (3.2.1)
+ sass (3.2.3)
sass-rails (3.2.5)
railties (~> 3.2.0)
sass (>= 3.1.10)
tilt (~> 1.3)
- selenium-webdriver (2.25.0)
+ selenium-webdriver (2.27.1)
childprocess (>= 0.2.5)
libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
rubyzip
- sprockets (2.1.3)
+ sprockets (2.2.2)
hike (~> 1.2)
+ multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
thor (0.16.0)
tilt (1.3.3)
- treetop (1.4.11)
+ treetop (1.4.12)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.33)
+ tzinfo (0.3.35)
uglifier (1.3.0)
execjs (>= 0.3.0)
multi_json (~> 1.0, >= 1.0.2)
warden (1.2.1)
rack (>= 1.0)
- xpath (0.1.4)
+ websocket (1.0.4)
+ xpath (1.0.0)
nokogiri (~> 1.3)
PLATFORMS
ruby
DEPENDENCIES
- capybara (>= 1.1.2)
+ capybara (>= 1.1.4)
coffee-rails (~> 3.2.1)
cucumber-rails (>= 1.3.0)
- database_cleaner (>= 0.8.0)
+ database_cleaner (>= 0.9.1)
devise (>= 2.1.2)
- email_spec (>= 1.2.1)
+ email_spec (>= 1.4.0)
factory_girl_rails (>= 4.1.0)
jquery-rails
launchy (>= 2.1.2)
- mongoid (>= 3.0.6)
- mongoid-rspec (>= 1.4.6)
+ mongoid (>= 3.0.14)
+ mongoid-rspec (>= 1.5.5)
quiet_assets (>= 1.0.1)
- rails (= 3.2.8)
- rspec-rails (>= 2.11.0)
+ rails (= 3.2.9)
+ rspec-rails (>= 2.11.4)
sass-rails (~> 3.2.3)
uglifier (>= 1.0.3)
View
2  app/views/layouts/application.html.erb
@@ -9,7 +9,7 @@
<%= csrf_meta_tags %>
<%= yield(:head) %>
</head>
- <body>
+ <body class="<%= controller_name %> <%= action_name %>">
<div id="container" class="container">
<header>
<%= render 'layouts/navigation' %>
Please sign in to comment.
Something went wrong with that request. Please try again.