New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

owncloud 9 upgrade #975

Closed
Loki3000 opened this Issue Mar 10, 2016 · 13 comments

Comments

5 participants
@Loki3000
Copy link

Loki3000 commented Mar 10, 2016

Hi!
After upgrading to OC9 rainloop lost datadir. The reason is class OC_Config is no longer exists.
I have changed

if (class_exists('OC_Config'))
{
    $sData = rtrim(trim(OC_Config::getValue('datadirectory', '')), '\\/').'/';
}

to

$sData = rtrim(trim(OC::$server->getSystemConfig()->getValue('datadirectory', '')), '\\/').'/';

in RainLoopHelper.php, and now it's work well. So its need to upgrade app version.

@RainLoop

This comment has been minimized.

Copy link
Owner

RainLoop commented Mar 10, 2016

Thanks!

@ezraholm50

This comment has been minimized.

Copy link

ezraholm50 commented Mar 10, 2016

Thanks for the great ownCloud app, any update on when it gets shipped to OC 9?

@Schengawegga

This comment has been minimized.

Copy link

Schengawegga commented Mar 12, 2016

Thanks Loki for this very quick solution. My girlfriend was terrorising me, becaus the rainloop app was not working after upgrading owncloud. You saved my life ;-)

@pierre-alain-b

This comment has been minimized.

Copy link
Contributor

pierre-alain-b commented Mar 20, 2016

Thanks, it works very well within oC 9 with your patch!

@Loki3000

This comment has been minimized.

Copy link

Loki3000 commented Mar 20, 2016

Thanks, it works very well within oC 9 with your patch!

It's not patch. It's just a dirty hack to wait for an update:)

@Schengawegga

This comment has been minimized.

Copy link

Schengawegga commented Mar 23, 2016

today i want to send an email with an attachment. but its not possible to upload a file since OC9. did you´ve got another quick solution for this problem too?

@Loki3000

This comment has been minimized.

Copy link

Loki3000 commented Mar 23, 2016

I sent a letter with the attachment without any problems.
Seems that your trouble are not connected with the new version of OC.

@Loki3000

This comment has been minimized.

Copy link

Loki3000 commented Mar 23, 2016

Try to check permissions to

data/rainloop-storage/_data_XXX/_default_/storage/files/...

It's place for store uploaded files.

@Schengawegga

This comment has been minimized.

Copy link

Schengawegga commented Mar 23, 2016

After the OC Upgrade, the permissions to this folder are set to 777:www-data. i´ve done a chown with www-data:www-data and it workes. Thanks a lot for this clue Loki.

@ezraholm50

This comment has been minimized.

Copy link

ezraholm50 commented Mar 23, 2016

After the OC Upgrade, the permissions to this folder are set to 777:www-data. i´ve done a chown with www-data:www-data and it workes. Thanks a lot for this clue Loki.

The ownership you mean by that right? I cant find the folder @Loki3000, and why is it set to 777, there must have been a typo somewhere but 777 on files?

@Schengawegga

This comment has been minimized.

Copy link

Schengawegga commented Mar 23, 2016

The ownership you mean by that right? I cant find the folder @Loki3000, and why is it set to 777, there must have been a typo somewhere but 777 on files?
yes, it´s the ownership. You can find the the folder in your owncloud/data/rainloop-storage/... folder.

@ezraholm50

This comment has been minimized.

Copy link

ezraholm50 commented Mar 23, 2016

No folder like that anywhere on my data directory... strage

@RainLoop

This comment has been minimized.

Copy link
Owner

RainLoop commented May 17, 2016

Last version should work with ownCloud 9.

@RainLoop RainLoop closed this May 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment