Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot use hyper operator on $_ by doing .».method #6050

Open
p6rt opened this issue Feb 3, 2017 · 2 comments
Open

Cannot use hyper operator on $_ by doing .».method #6050

p6rt opened this issue Feb 3, 2017 · 2 comments

Comments

@p6rt
Copy link

@p6rt p6rt commented Feb 3, 2017

Migrated from rt.perl.org#130710 (status was 'new')

Searchable as RT130710$

@p6rt

This comment has been minimized.

Copy link
Author

@p6rt p6rt commented Feb 3, 2017

From @samcv

$_ = (' a ', ' b '); $_.».trim.perl.say
OUTPUT​:
$("a", "b")

$_ = (' a ', ' b '); $_.».trim.perl.say
OUTPUT​:
===SORRY!=== Error while compiling​:
Malformed postfix call (only alphabetic methods may be detached)
------> $_ = (' a ', ' b '); .⏏».trim.perl

@p6rt

This comment has been minimized.

Copy link
Author

@p6rt p6rt commented Feb 3, 2017

From @samcv

The second code should have been​:
$_ = (' a ', ' b '); .».trim.perl.say

which does have the error message.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.